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FEATURES 
ADPD2140 full configuration 

Register level 
Parameter level 

Graph views 
Time series view 
Gesture recognition view 
Triangulation view 

UDP transfer capability 

EVALUATION KIT CONTENTS 
EVAL-ADPD2140Z standard evaluation board 
USB-C cable 

ADDITIONAL EQUIPMENT NEEDED 
EVAL-ADPDM3Z evaluation board 
PC running Windows® 7 operating system 

ONLINE RESOURCES 
ADPD2140 data sheet 
Applications Wavetool 

GENERAL DESCRIPTION 
The EVAL-ADPD2140Z evaluation kit allows users to interface 
with the ADPD2140 infrared (IR) light angle sensor, collect data 
from the ADPD2140, and evaluate gesture recognition and 
triangulation capabilities. 

The evaluation kit requires the EVAL-ADPDM3Z evaluation 
board and the Applications Wavetool, a graphical user interface 
(GUI) that provides users with low level and high level config-
urability, real-time data analysis, and user datagram protocol 
(UDP) transfer capability, which allows the EVAL-ADPDM3Z 
evaluation board to interface to a PC. The Applications 
Wavetool can be downloaded from the EVAL-ADPD2140Z 
evaluation board product page. 

The USB port of the PC powers the EVAL-ADPDM3Z 
evaluation board and provides power to the EVAL-ADPD2140Z 
evaluation board. On-board voltage regulators provide voltage 
supplies for the ADPD2140. 

The EVAL-ADPD2140Z evaluation board schematic indicates 
signal names for easy identification (see Figure 12). 

Full specifications for the ADPD2140 are available in the 
ADPD2140 data sheet, which should be consulted in conjunction 
with this user guide when working with the EVAL-ADPD2140Z 
evaluation board. 

EVALUATION BOARD PHOTOGRAPH 
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Figure 1. 

http://www.analog.com/ADPD2140?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/ADPD2140?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/EVAL-ADPD2140Z?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/ADPD2140?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/EVAL-ADPD2140Z?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/ADPD2140?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/ADPD2140?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/EVAL-ADPD2140Z?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/EVAL-ADPD2140Z?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/EVAL-ADPD2140Z?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/EVAL-ADPD2140Z?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/EVAL-ADPD2140Z?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/ADPD2140?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/ADPD2140?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/ADPD2140?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/EVAL-ADPD2140Z?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com
http://www.analog.com/EVAL-ADPD2140Z?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/EVAL-ADPD2140Z?doc=EVAL-ADPD2140Z-UG-1358.pdf
http://www.analog.com/EVAL-ADPD2140Z?doc=EVAL-ADPD2140Z-UG-1358.pdf


UG-1358 EVAL-ADPD2140Z User Guide 

Rev. 0 | Page 2 of 7 

TABLE OF CONTENTS 
Features .............................................................................................. 1 
Evaluation Kit Contents ................................................................... 1 
Additional Equipment Needed ....................................................... 1 
Online Resources .............................................................................. 1 
General Description ......................................................................... 1 
Evaluation Board Photograph ......................................................... 1 
Revision History ............................................................................... 2 
Evaluation Board Software Quick Start Procedures .................... 3 

Installing the Applications Wavetool ......................................... 3 

EVAL-ADPD2140Z Evaluation Board USB Connection ........3 
Updating the EVAL-ADPDM3Z Evaluation Board Firmware ....4 
Configuring the EVAL-ADPD2140Z Evaluation Kit ...................4 
Streaming Data ..............................................................................4 
Gesture Device ...............................................................................4 
Angle Device ..................................................................................5 

Evaluation Board Schematics and Artwork ...................................6 

REVISION HISTORY 
8/2018—Revision 0: Initial Version 

http://www.analog.com/EVAL-ADPD2140Z?doc=EVAL-ADPD2140Z-UG-1358.pdf


EVAL-ADPD2140Z User Guide UG-1358
 

Rev. 0 | Page 3 of 7 

EVALUATION BOARD SOFTWARE QUICK START PROCEDURES 
INSTALLING THE APPLICATIONS WAVETOOL 
Download the Applications Wavetool software package from the 
EVAL-ADPD2140Z evaluation board product page. Unzip the 
downloaded software folder, run the enclosed Applications_ 
Wavetool_1853.exe file, and follow the prompts for installing the 
Applications Wavetool software (see Figure 2). 
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Figure 2. Applications Wavetool Setup 

To start the Applications Wavetool application, navigate to the 
ApplicationsWavetool folder from the Start menu and click the 
Applications Wavetool icon (see Figure 3). 
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Figure 3. Navigate to the ApplicationsWavetool Folder from the Start Menu 

At startup, the Applications Wavetool application automatically 
checks if the installed Applications Wavetool software version is 
up to date. If there is a newer version available, the user is prompted 
to download the newest version. 

RESET BOOT
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Figure 4. EVAL-ADPDM3Z Evaluation Board 

EVAL-ADPD2140Z EVALUATION BOARD USB 
CONNECTION 
Prior to starting the Applications Wavetool application, connect 
the EVAL-ADPD2140Z evaluation board to the EVAL-ADPDM3Z 
evaluation board via the board to board connectors. Connect the 
EVAL-ADPDM3Z evaluation board to a PC via the USB-C 
cable included with the evaluation kit. The PC automatically 
finds the device drivers and installs them if they have not been 
previously installed. When the EVAL-ADPDM3Z evaluation 
board is connected, open the Applications Wavetool application 
(see Figure 5). 
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Figure 5. Applications Wavetool Window 

After the Applications Wavetool application opens, click 
Connection > Connect to open the communication (COM) 
port selection window. Select the appropriate COM port from 
the Connect dropdown menu and click Connect (see Figure 6). 
The Applications Wavetool then acknowledges that the EVAL-
ADPD2140Z evaluation board is connected by displaying M3 
Motherboard Found on the screen. 
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Figure 6. COM Port Selection Window 
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UPDATING THE EVAL-ADPDM3Z EVALUATION 
BOARD FIRMWARE 
If the EVAL-ADPDM3Z evaluation board firmware is out of 
date, the software displays a warning, as shown in Figure 7. If 
this warning occurs, click Tools > Firmware Update from the 
main window, and click Ok in the dialog box. Follow the 
instructions shown in Figure 7 to update the EVAL-ADPDM3Z 
evaluation board firmware. 
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Figure 7. Updating the EVAL-ADPDM3Z Evaluation Board Firmware 

CONFIGURING THE EVAL-ADPD2140Z EVALUATION 
KIT 
To operate the EVAL-ADPD2140Z evaluation board in gesture 
detect mode, click View > Gesture Device. Click ADPD 
Config to enter the gesture configuration window. Click Load 
DCFG, select ADPD1080Z-GST_Gesture.dcfg, and click Open 
(see Figure 8).  
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Figure 8. Loading the Configuration File 

By default, this file configures the EVAL-ADPD2140Z evaluation 
board to use the LEDX1 light emitting diode (LED) driver, 
which is optimized for gesture recognition. After loading the 
configuration file, click Power Calculation, which opens a new 
window. Press M on the keyboard. In the new window, under 
Boost Enable, ensure that the Boost Enable check box is 
selected (see Figure 9). This control is automatically selected 
upon connecting the EVAL-ADPD2140Z evaluation board and 
the EVAL-ADPDM3Z evaluation board to the PC. 
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Figure 9. Boost Enable Selection 

STREAMING DATA 
Return to the Gesture Device window and click the Play icon to 
begin streaming data from the EVAL-ADPD2140Z evaluation 
board. Move an object or hand within 30 cm above the EVAL-
ADPD2140Z evaluation board to see the corresponding output 
of the device on the graphs. The Y Ratio vs X Ratio graph 
shows the calculated x and y positions of the object above the 
device (see Figure 10). The Raw Data graph shows the four data 
output channels (xR, xL, yT, and yB) change as a function of 
reflected light seen by the device, represented in analog-to-digital 
converter (ADC) codes. In the Y Ratio vs X Ratio graph, an 
offset of 255 codes is applied to all four channels to prevent 
division by zero in the calculation of x and y. See the ADPD2140 
data sheet for more information. 
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Figure 10. Gesture Device Window 

GESTURE DEVICE 
To view the gesture recognition capability, remain in the 
Gesture Device window with data streaming turned on. 

Move a hand or other reflective object within 30 cm above the 
device and swipe in any of the four indicated directions. 
Alternatively, the center indicator can be activated by quickly 
lowering an object towards the sensor. 
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ANGLE DEVICE 
To view the x and y response and triangulation data, stop data 
streaming by clicking the Stop icon. Exit the Gesture Device 
window and click View > Angle Device in the Applications 
Wavetool main application window. Click ADPD Config to 
open the configuration window. Click Load DCFG and select 
ADPD1080Z-GST_Angle_nominal_01.dcfg to load the trian-
gulation settings. 

Return to the Angle Device window. Click the Play icon to 
begin streaming data. Ensure that no objects are within 50 cm 
of the EVAL-ADPD2140Z evaluation board and then select the 
Zero Offsets check box. 

Move a hand or other reflective object within 20 cm directly above 
the device. The Y Ratio vs X Ratio graph shows the x and y data 
without added offsets. On the right side, the Log Intensity field 
shows the log of the sum of the four channels. The Distance (mm) 
field shows the distance calculated through triangulation of the 
angles seen by the two ADPD2140 devices on the EVAL-
ADPD2140Z evaluation board (see Figure 10). 
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Figure 11. Angle Device Window 

For more detailed information on the Applications Wavetool and 
additional features of the software, see the Applications Wavetool 
user manual, which can be found in the Help > Help Topics 
menu. 
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EVALUATION BOARD SCHEMATICS AND ARTWORK 
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Figure 12. EVAL-ADPD2140Z Evaluation Board Schematic 
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Figure 13. EVAL-ADPD2140Z Evaluation Board Layout 

ESD Caution  
ESD (electrostatic discharge) sensitive device. Charged devices and circuit boards can discharge without detection. Although this product features patented or proprietary protection 
circuitry, damage may occur on devices subjected to high energy ESD. Therefore, proper ESD precautions should be taken to avoid performance degradation or loss of functionality. 

Legal Terms and Conditions 
By using the evaluation board discussed herein (together with any tools, components documentation or support materials, the “Evaluation Board”), you are agreeing to be bound by the terms and conditions 
set forth below (“Agreement”) unless you have purchased the Evaluation Board, in which case the Analog Devices Standard Terms and Conditions of Sale shall govern. Do not use the Evaluation Board until you 
have read and agreed to the Agreement. Your use of the Evaluation Board shall signify your acceptance of the Agreement.  This Agreement is made by and between you (“Customer”) and Analog Devices, Inc. 
(“ADI”), with its principal place of business at One Technology Way, Norwood, MA 02062, USA. Subject to the terms and conditions of the Agreement, ADI hereby grants to Customer a free, limited, personal, 
temporary, non-exclusive, non-sublicensable, non-transferable license to use the Evaluation Board FOR EVALUATION PURPOSES ONLY. Customer understands and agrees that the Evaluation Board is provided 
for the sole and exclusive purpose referenced above, and agrees not to use the Evaluation Board for any other purpose. Furthermore, the license granted is expressly made subject to the following additional 
limitations: Customer shall not (i) rent, lease, display, sell, transfer, assign, sublicense, or distribute the Evaluation Board; and (ii) permit any Third Party to access the Evaluation Board. As used herein, the term 
“Third Party” includes any entity other than ADI, Customer, their employees, affiliates and in-house consultants. The Evaluation Board is NOT sold to Customer; all rights not expressly granted herein, including 
ownership of the Evaluation Board, are reserved by ADI. CONFIDENTIALITY. This Agreement and the Evaluation Board shall all be considered the confidential and proprietary information of ADI. Customer may 
not disclose or transfer any portion of the Evaluation Board to any other party for any reason. Upon discontinuation of use of the Evaluation Board or termination of this Agreement, Customer agrees to 
promptly return the Evaluation Board to ADI. ADDITIONAL RESTRICTIONS. Customer may not disassemble, decompile or reverse engineer chips on the Evaluation Board. Customer shall inform ADI of any 
occurred damages or any modifications or alterations it makes to the Evaluation Board, including but not limited to soldering or any other activity that affects the material content of the Evaluation Board. 
Modifications to the Evaluation Board must comply with applicable law, including but not limited to the RoHS Directive. TERMINATION. ADI may terminate this Agreement at any time upon giving written notice 
to Customer. Customer agrees to return to ADI the Evaluation Board at that time. LIMITATION OF LIABILITY. THE EVALUATION BOARD PROVIDED HEREUNDER IS PROVIDED “AS IS” AND ADI MAKES NO 
WARRANTIES OR REPRESENTATIONS OF ANY KIND WITH RESPECT TO IT. ADI SPECIFICALLY DISCLAIMS ANY REPRESENTATIONS, ENDORSEMENTS, GUARANTEES, OR WARRANTIES, EXPRESS OR IMPLIED, RELATED 
TO THE EVALUATION BOARD INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTY OF MERCHANTABILITY, TITLE, FITNESS FOR A PARTICULAR PURPOSE OR NONINFRINGEMENT OF INTELLECTUAL 
PROPERTY RIGHTS. IN NO EVENT WILL ADI AND ITS LICENSORS BE LIABLE FOR ANY INCIDENTAL, SPECIAL, INDIRECT, OR CONSEQUENTIAL DAMAGES RESULTING FROM CUSTOMER’S POSSESSION OR USE OF 
THE EVALUATION BOARD, INCLUDING BUT NOT LIMITED TO LOST PROFITS, DELAY COSTS, LABOR COSTS OR LOSS OF GOODWILL. ADI’S TOTAL LIABILITY FROM ANY AND ALL CAUSES SHALL BE LIMITED TO THE 
AMOUNT OF ONE HUNDRED US DOLLARS ($100.00). EXPORT. Customer agrees that it will not directly or indirectly export the Evaluation Board to another country, and that it will comply with all applicable 
United States federal laws and regulations relating to exports. GOVERNING  LAW. This Agreement shall be governed by and construed in accordance with the substantive laws of the Commonwealth of 
Massachusetts (excluding conflict of law rules). Any legal action regarding this Agreement will be heard in the state or federal courts having jurisdiction in Suffolk County, Massachusetts, and Customer hereby 
submits to the personal jurisdiction and venue of such courts. The United Nations Convention on Contracts for the International Sale of Goods shall not apply to this Agreement and is expressly disclaimed. 
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