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Introduction 

Analog Devices Inc. released a product 
discontinuance notification (PD13_0091

[2]
) for 

ADSP-BF51xF Blackfin® processors describing 
SPI flash memory die changes. Specifically, 

ADSP-BF51xF4 devices containing an 
embedded SST25WF040[4]

 SPI flash memory die 
were discontinued and replaced by ADSP-
BF51xF16[1]

 devices containing an embedded 

S25FL116K
[5]

 SPI flash memory die. This 
change requires adjustments to existing drivers 
that were developed to communicate with the on-
chip SPI flash memory. 

This EE-Note describes the modifications 
required for the existing VisualDSP++® flash 

programmer utility to work with the new ADSP-
BF51xF16 devices, which can be used as a 
guideline for any custom-developed drivers. In 
addition, for CrossCore® Embedded Studio 

(CCES) users, a new driver for use with the 
CCES Command Line Device Programmer 
(CLDP) is introduced, which can also serve as a 
boilerplate for any custom SPI memory device 
drivers under CCES.  

While the CCES driver provided with 

this EE-Note will only support ADSP-
BF51xF16 devices, VisualDSP++ driver 
supports both ADSP-BF51xF16 and 
ADSP-BF51xF4 devices. 

VisualDSP++ Flash Programmer 
Utility Modifications 

VisualDSP++ flash programmer utility is an 
embedded program that runs on ADSP-BF51x 
Blackfin processor core to configure the SPI port 
and properly communicate with the on-chip SPI 

flash memory device. This includes sector 
program/fill/erase commands, as well as 
functions like chip erase. Inclusive of these 
commands is the ability to program the SPI flash 

memory with the application boot loader image 
(.LDR file) so that the processor can boot from 
the internal flash. 

VisualDSP++ flash programmer utility (release 

5.1.1 or later) uses the device driver for the 
SST25WF040 memory, which only supports the 
ADSP-BF51xF4 devices. This driver, however, 
can be modified to also work with the new 

S25FL116K memory die present in the ADSP-
BF51xF16 devices. 

The associated .ZIP file includes a VisualDSP++ 
project for the flash programmer utility in the 

VDSPInternalSPI folder.  

To open the driver from the VisualDSP++ tools, 
select File->Open->Project and navigate to this 
folder. Then select the project file 

BF518FEzFlashDriver_SST25WF040.dpj. 

Support for the S25FL116K memory was added 
in the detection portion of the code such that the 
S25FL116K flash device can be recognized and 

communicated with properly. The two files that 
required modification are the 
VDSPInternalSPI\sst25wf040.h and 

VDSPInternalSPI\sst25wf040.c. 
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Modifying sst25wf040.h 

This file defines the manufacturer/capacity 
JEDEC ID codes and the number of physical 
sectors for the memory device, which were 
added for the S25FL116K flash device from the 
memory data sheet

[5]
, as shown in Listing 1: 

/* ids for S25FL116K SPI Flash */ 

/* Spansion, Inc. */ 

#define MAN_CODE_SPANSION  0x01 

 

/* S25FL116K (16Mbit SPI flash) */ 

#define DEV_CODE_S25  0x15 

 

/* num sectors */ 

#define NUM_SECTORS_S25 512 

Listing 1. JEDEC ID Modifications 

These #defines supporting the S25FL116K 

flash memory were added after the #defines for 
the original SST25WF040 flash memory. 

Modifying sst25wf040.c 

The sst25wf040.c file contains the main 
functions for opening, closing, writing and 

reading the flash device. In this file, support was 
added for: 

 Start and end addressing 
 Detecting the S25FL116K SPI flash ID 

Start and End Addresses 

The VisualDSP++ driver requires mapping of the 
beginning and end of the available storage space. 

As such, the following #defines were added at 
line 26, as shown in Listing 2: 

/* Spansion S25FL116K Start and End 

Address - 16Mbit SPI Flash*/ 

#define START_ADDRESS_S25   0x0 

#define END_ADDRESS_S25     0x001fffff   

/* 2 Mbyte */  

Listing 2. S25FL116K Memory Address Range 

Detecting the S25FL116K SPI Flash ID 

When the driver first opens, it reads the device 
ID from the SPI memory. Support to recognize 
the S25FL116K flash during this operation was 

added at line 190 via an additional if 
statement, as shown in Listing 3. 

Once the S25FL116K is detected, the number of 
sectors, description, and company name are setup 

so the proper configuration appears in the flash 
programmer utility. Also, the SPI0 baud rate is 
increased to speed up writing to and erasing the 
much larger S25FL116K flash device. 

Due to the larger capacity of the 
S25FL116K versus the previous flash 

memory device, VisualDSP++ tools 
may appear to lock up during 
erase/programming operations. It may 
take several minutes depending on the 
emulation device. 

// Check if device is S25FL116K 

else if(DEV_CODE_S25 == g_DevId) 

{ 

 // 512 4KB sectors  

 gNumSectors = 512; 

 // Change Flash description 

 pFlashDesc = "S25FL116K"; 

 // Change flash company name 

 pDeviceCompany = "Spansion, Inc."; 

 // Increase SPI0 baud 

 *pSPI0_BAUD = 0x2; 

} 

Listing 3. S25FL116K Device Detection/Configuration 

Booting from SPI Flash Memory 

To build the flash programmer utility driver, 
select Project->Build Project in your 
VisualDSP++ session. The executable file (.DXE) 

will be located in the VDSPinternalSPI folder.  

As the flash programmer utility GUI 

makes use of embedded debug 
information, make sure that the driver is 
built in Debug mode (default), and not 
in Release mode. 
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Once the new driver is built, the flash 
programmer utility GUI must be directed to it. 
Make sure a powered target board is connected 

via a VisualDSP++ emulator session and select 
Tools->Flash Programmer, which opens the 
GUI. On the Driver tab, click the […] browse 

button next to the Driver file  dialog box, 
navigate to the VDSPInternalSPI folder, and 

select the new driver that was just built, 
BF518FEzFlashDriver_SST25WF040.dxe. 

When Load Driver is clicked, the Flash 

Information from Listing 1 and Listing 3 should 
appear, and the new ADSP-BF51xF16 device is 

now supported by the same tools used with the 
previous ADSP-BF51xF4 devices. If the target 
board were swapped with a board featuring the 
ADSP-BF51xF4 device, this same driver when 

loaded would reflect the Flash Information for 
the SST25WF040 SPI flash die and function 
identically. 

CCES Considerations 

The flash programmer utility present in the 
VisualDSP++ tools is not currently supported in 

the CCES development tools. Rather, there is a 
Command Line Device Programmer (CLDP) that 
is used to program memory devices.  

Similar to the VisualDSP++ flash programmer 
utility, the CCES CLDP tool also requires a 
memory device driver to properly communicate 

with the connected SPI memory. However, 
because the device driver API was significantly 
changed from VisualDSP++ to CCES, the driver 
had to be created from scratch for the 

S25FL116K memory embedded in ADSP-
BF51xF16 devices.  

This driver can be used as the baseline for similar 
SPI flash memory drivers required by customer 
applications. 

Importing and Building the Driver in CCES 

The .ZIP file associated with this EE-Note 

includes a CCES project for the flash memory 
device driver in the CCESInternalSPI folder. To 
import the project in the CCES tools: 

 Select File->Import. 

 Select Existing Projects into 
Workspace  and click Next. 

 Ensure Select root directory is selected, 
and click the associated Browse... button. 

 The Browse For Folder window opens. 

Navigate to the CCESInternalSPI folder 
and click OK. 

Once the project is imported, the driver 
executable (.DXE file) can be built by using the 

Project->Build Project pull-down, and the 
output .DXE file will be located in the 

CCESInternalSPI\serial\Debug folder. This is 

what the CLDP will use to program the boot 
image into the on-chip flash. However, the driver 
code itself can be modified to support other SPI 
flash memory devices, as described next. 

S25FL116K Driver Files 

In the Project Explorer view, click the arrow 
next to the bf518f_s25fl116k_dpia project 

name to list the source files. The relevant files 
for the CCES S25FL116K SPI flash memory 
driver code are included in the 
CCESInternalSPI\serial\src directory: 

bf518f_s25fl116k_dpia.c 

\s25fl116k\s25fl116k.c 

Supported JEDEC Commands 

The S25FL116K flash supports the same basic 

JEDEC flash memory command structure as the 
SST25WF040 featured on the ADSP-BF51xF4 
devices, namely those depicted in Table 1. 
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Command Name Instruction 

READ_DATA 0x03 

FAST_READ 0x0B 

SECTOR_ERASE 0xD8 

BULK_ERASE 0xC7 

PAGE_PROGRAM 0x02 

READ_STATUS_REGISTER 0x05 

WRITE_STATUS_REGISTER 0x01 

WRITE_ENABLE 0x06 

WRITE_DISABLE 0x04 

JEDEC_ID 0x9F 

READ_SIGNATURE 0xAB 

Table 1. Supported Flash Commands 

The #defines for the instructions are located in 

the s25fl116k.c file starting at line 5, and 

additional commands can be added as needed to 
support other memories. 

JEDEC ID 

Unlike the VisualDSP++ device driver, this 
device driver uses three parts of the JEDEC ID to 

identify the connected flash device - the 
Manufacturer’s ID, the Memory Type ID, and 
the Capacity ID. These three IDs help identify 
various flash devices and allow the driver to 

select the correct sector map table and command 
structure. The JEDEC ID for the S25FL116K 
flash memory is shown in Table 2: 

JEDEC ID Value 

Manufacture ID 0x01 

Memory Type ID 0x40 

Capacity ID 0x15 

Table 2. JEDEC ID Information for S25FL116K 

The JEDEC ID can be changed in the 
s25fl116k.c file starting at line 320, as shown 
in Listing 4. 

 

struct flash_info s25fl116k_info = 

"s25fl116k", /* name */ 

 "Spansion", /* name */ 

  0x01,      /* manufacturer ID */  

  0xff,      /* 0xff */ 

  0x40,  /* memory type */ 

  0x15,  /* capacity ID */ 

  STANDARD, /* supported modes */ 

Listing 4. JEDEC ID Code 

SPI Slave-Select Pin 

On ADSP-BF51xFy devices, the SPI Slave-

Select pin (PH8) is internally routed as a 
dedicated chip-select for the internal SPI flash 

memory. In the bf518f_s25fl116k_dpia.c 
source file, line 44 configures the SPI Slave-

Select pin along with the SPI pins for SCK, 
MISO and MOSI. Make sure that the Slave-

Select is set for PH8 for the internal SPI select to 
operate. 

Flash Sector Map 

Each flash memory device has a unique sector 

map, which is based on the memory size and 
memory block configuration. The sector map is 
required for the programmer driver to determine 
which blocks of memory require erasing prior to 
a new write operation. 

The S25FL116K is configured into 512 sectors, 

each containing 4 kB (0x1000 bytes). The sector 
map can be configured in the s25fl116k.c file 

in the following #defines starting at line 26 
(Listing 5): 

#define NUM_SECTORS 512 

#define SECTOR_SIZE 0x1000 

Listing 5. Sector Map Code 



   

 

Flash Programmer Drivers for ADSP-BF51xF16 Blackfin® Processors (EE-367) Page 5 of 5 

Using the CLDP to Program ADSP-BF51xF16 
Processors 

The CLDP utility for CCES (cldp.exe) is 
located in the root installation folder (default): 

\Analog Devices\CrossCore Embedded 
Studio CCES_version_number\ 

To program the ADSP-BF51xF16 device with 

the loader image for an application called 
app.ldr, make sure a powered target board is 

connected via emulator, and open a Windows 
command prompt (cmd.exe). Navigate to the 

root path for the CCES installation and use the 
following command: 

cldp.exe –proc ADSP-BF518 –emu HPUSB –

driver 

“C:\CCESInternalSPI\serial\Debug\bf518f

_s25fl116k_dpia.dxe” –cmd prog –erase 

affected –format hex –file “app.ldr”

 

This command line assumes the 

connected target is the ADSP-BF518 
EZ-KIT board via the HPUSB-ICE 
emulator and that the associated .ZIP 

archive was extracted to the C:\ root 
directory. The processor, emulator, 
driver pathname, and/or .ldr file name 
may need to be modified. 

More information on the CLDP can be 
found in CCES On-Line Help. 
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