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ADuCM310 Development Systems Getting Started Tutorial
DEVELOPMENT SYSTEM KIT CONTENTS

GENERAL DESCRIPTION

Evaluation board (EVAL-ADUCM310QSPZ) that facilitates
performance evaluation of the device with a minimum
of external components
Analog Devices, Inc., J-Link OB emulator
(USB-SWD/UART-EMUZ)
1 USB cable
1 installation DVD

The ADuCM310 development system allows evaluation of
ADuCM310 silicon. This quick start guide introduces the
support features and the tools supplied with the evaluation kit.
In addition, this user guide shows and describes how to connect
the evaluation hardware.

INTRODUCTION
The ADuCM310 is a multidie stack system on-chip for
diagnostic control of tunable laser optical module applications.
The ADuCM310 features a 14-bit, multichannel, successive
approximation register analog-to-digital converter (SAR ADC);
an ARM® Cortex-M3 processor; eight voltage DACs; six current
output DACs; and Flash/EE memory packaged in a 6 mm × 6 mm,
112-ball CSP_BGA package.

This user guide works as a tutorial by providing a step-by-step
account of how to download evaluation versions of third-party
software tools. Instructions are provided on how to load code
examples that are supplied.
By working through this guide, users can start to generate and
download their own user code for use in their own unique endsystem requirements.
Full specifications on the ADuCM310 are available in the
product data sheet, which should be consulted in conjunction
with this user guide when working with the evaluation kit.
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TYPICAL SETUP

Figure 1. EVAL-ADUCM310QSPZ Evaluation Board and Analog Devices J-Link OB Emulator

PLEASE SEE THE LAST PAGE FOR AN IMPORTANT
WARNING AND LEGAL TERMS AND CONDITIONS.
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GETTING STARTED
missed, run Setup_JLink_Vxxxx.exe located in the Segger folder
on the DVD. After this step, if there is an issue with the drivers,
the drivers can be reinstalled from Program Files\SEGGER\
JLinkARM_Vxxxx\USBDriver. The CDC driver must be
installed.

SOFTWARE INSTALLATION PROCEDURES
Perform the steps described in this section before plugging any
of the USB devices into the PC.
Close all open applications.
Insert the installation DVD into your DVD drive.
Double-click ADuCM310.exe and follow the on-screen
instructions. A dialog box displays installation options, as
shown in Figure 2.

13100-003

1.
2.
3.
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Figure 3. Installing J-Link Software

Figure 2. Installation Options

The following are installed on the PC by default:



Example code and function sets for most peripherals
Elves.exe: an application with which functions can be easily
chosen from the provided function sets; the user can then
choose the function parameters.
CM3WSD.exe: an application for downloading hex file to
the ADuCM310 over UART.






1.

2.

The user also has the option to install the following:


Future updates will be available from the Analog Devices
FTP site.
When the software installation is completed, plug the
debugger/programmer into the USB port of your PC using
the USB cable supplied.
Verify that the emulator board appears in the Windows®
Device Manager (see Figure 4).

Keil development tools (compiler, debugger, and
programming tools). The revision used is V5.14. Analog
Devices has developed a CMSIS software pack to support
the ADuCM310.
IAR development tools (compiler, debugger, and
programming tools).
FTDI drivers for the evaluation board.
PLAToolM3: an application for configuring the PLA
peripheral on the ADuCM310.
Segger J-Link software: this is the software and drivers for
the emulator.

The Segger J-Link software is selected by default in the installation
menu. It is advised to leave it selected, which automatically
installs the J-Link serial port driver. Select Install USB Driver
for J-Link-OB with CDC, as shown in Figure 3. If this step is
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If the IAR tools are to be used, the entire contents of the
supplied arm directory (for example, C:\ADuCM310…\
IAR\IAR_M310_Patch.zip\arm) must be copied to the IAR
tools directory (for example, C:\Program Files\IAR Systems\
Embedded Workbench 7.2\arm).

Figure 4. Device Manager
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EVALUATION BOARD SETUP PROCEDURES
Assembling the Hardware
Do not plug in the USB cable before the software is installed.

Connecting the Hardware

4.

5.

6.
7.



8.

Figure 6. J-Link OB Connection Details

KEIL μVISION5
The Keil μVision5 integrated development environment (IDE)
integrates all the tools necessary to edit, assemble, and debug
code. The free version that ships with the ADuCM310
evaluation kit is limited to 32 kB code.

Starting μVision5
First, ensure that the CMSIS pack for the ADuCM310 has been
installed (see the Software Installation Procedures section).
After installing Keil μVision5, a shortcut appears on the
desktop. Double-click the shortcut to open Keil μVision5.

A voltage between 6 V and 20 V to J5.
A voltage between 6.7 V and 20 V to J1. Note that the
J1 connector is center ground and outside positive.
13100-007

3.

The green power LED turns on.

Figure 7. Keil μVision5 Desktop Shortcut

1.

When Keil opens, click the Pack Installer button on the
toolbar.

13100-008

2.

Insert the USB cable provided between the PC and the
J-Link OB emulator.
The red LED (LED1) flashes briefly until initialization of
the drivers is complete.
Driver installation details may appear on your screen;
allow the installation of these drivers to complete, because
these drivers provide a virtual communication port on
your PC, allowing the evaluation board to appear as a
virtual serial communication port to the UART port of the
ADuCM310 device.
Note that the emulator drives P1.0 of the ADuCM310 high.
If P1.0 is needed for other uses, LK5 on the emulator can
be removed.
If the virtual serial communication port to the UART is to
be used, ensure that Jumper LK3 and Jumper LK5 are in
place (see Figure 6). If the UART on J8 is to be used, LK3
and LK5 must be removed to prevent contention.
Plug the 10-pin DIL connector of the J-Link OB emulator
into the EVAL-ADUCM310QSPZ.
To power up the evaluation board, apply a 2.5 V supply
capable of providing up to 2 A of current for the IDACs,
and one of the following:

Figure 8. Pack Installer Button
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1.

13100-006

Take the following steps to connect the hardware:

Figure 5. Emulator, Top View
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The Pack Installer window opens.

4.

In the left-hand side of the window, click the Examples tab.

13100-009

2.
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Figure 9. Pack Installer Window

From the right-hand portion of the window, under the
Devices tab, click Analog Devices > ADuCM310 Series >
ADuCM310.

13100-010

Figure 10. Devices Tab
13100-011

3.

Figure 11. Examples Tab

5.
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Select the DIO example and click copy.

UG-829
Choose a destination folder and click ok. It is recommended
to place your projects under C:\ADuCM310Vx.x\code\
ADuCM310\MyProjects. This copies the DIO example,
necessary startup files, and library functions to the folder
of your choice.

10. When the download is complete, the message shown in
Figure 16 appears.

13100-012

6.
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Figure 12. DIO Example

The example must to be compiled by clicking the Build
button on the toolbar, or by pressing the F7 key.

13100-016

7.

Figure 16. Download Message
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11. After the code is downloaded to the board, press the reset
button on the evaluation board. The red DISPLAY starts
toggling.
12. The code can be debugged by clicking the Debug button.

Figure 13. Build Button

When the build has completed, the message shown in
Figure 14 appears.
13100-017

8.

Figure 14. Build Output

To download the code to the EVAL-ADUCM310QSPZ
board, click the Download button.

13100-015

9.

13. Breakpoints can be added by clicking the breakpoint
button. The ADuCM310 is limited to two hardware
breakpoints. The J-Link software comes with an evaluation
version of unlimited flash breakpoints, which work by
reprogramming the ADuCM310 flash to add a special
instruction that the debugger is aware of.
14. The execution of the code on the ADuCM310 can be
controlled using the Debug toolbar. The ADuCM310 can
be reset, the program can be started and stopped, and it is
possible to step through the code. Note that stepping
through the code uses one of the two available hardware
breakpoints.
13100-018

13100-014

Figure 17. Debug Button

Figure 15. Download Button
Figure 18. Debug Toolbar
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13100-021

15. The registers for the various peripherals on the ADuCM310
can be viewed by going to the Peripherals menu and
selecting the System Viewer submenu. The registers can be
read and written to here. The registers can also be expanded
to obtain the bit information and possible enumerations
that can be used for certain bits. Note that reading certain
status registers or reading from FIFO registers can affect
the normal operation of code; therefore, the user is advised
to be cautious with the use of System Viewer.

Figure 19. System Viewer Menu

17. The libraries are documented with Doxygen comments,
which can be interpreted by the Elves program. The Elves
program provides a GUI that can be used to select the
correct parameters to be passed to a library function. For
more information, see the Elves section.

13100-020

16. After a debug session is complete, new code can be written
and rebuilt. Included in the evaluation kit is an extensive
set of library functions. These can be included in a project
with the Manage Run-Time Environment button. The
libraries can be found under the Device > Peripheral
Libraries category, as shown in Figure 21.

Figure 21. Adding Peripheral Libraries to a Project

Figure 20. Manage Run-Time Environment Button
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IAR EWARM
The EWARM integrated development environment (IDE)
integrates all the tools necessary to edit, assemble, and debug
code. The fastest way to get started is to open an existing
workspace by taking the following steps:

2.

3.

4.
5.

Open the IAR tools from the start menu, IAR
Systems\...\IAR Embedded Workbench.
Within the IAR IDE, click File > Open > Workspace, and
open a workspace provided (for example, C:\ADuCM310…\
code\ADuCM310\examples\DIO\DIO.eww).
Compile and download to the device by clicking Project >
Rebuild All, and then clicking Project > Download Active
Application.
If a pop-up window about an unknown device appears,
click No.
To run the code, press reset on the board or enter debug
mode by using the Download and Debug button and then
clicking Go.

13100-026

1.

The peripheral registers can be read and modified using
the Register window, which can be accessed from the View
menu. Note that reading certain status registers or reading
from FIFO registers can affect the normal operation of
code; therefore, the user is advised to be cautious with the
use of the Register window.

Figure 26. Register Window
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ELVES
Elves.exe is an application that the user can use to easily choose
functions from the provided function sets, and then choose the
function parameters. Elves can be integrated into the Keil and
IAR tools under their tools menus. For instructions, run
Elves.exe (for example, at C:\ADuCM310…\Software Tools\
Elves\Elves.exe) and press the F1 key or click the Help button
for further instructions.

13100-023

Figure 22. Download and Debug Button

Figure 23. Go Button

6.

2.

The library files for a particular μVision5 project are copied
by μVision5 from the CMSIS pack to the RTE folder under
the project folder.
All the included libraries are available under
C:\ADuCM310Vx.x\code\ADuCM310\common. These
files can be used for both the IAR and the Keil installation.

13100-024

7.

1.

When the code is running, the red LED marked DISPLAY
on the board flashes.
Breakpoints can be enabled using the Toggle Breakpoint
button. The ADuCM310 is limited to two hardware
breakpoints. The J-Link software comes with an evaluation
version of unlimited flash breakpoints, which work by
reprogramming the ADuCM310 flash to add a special
instruction that the debugger is aware of.

Figure 24. Toggle Breakpoint Button

13100-027

In debug mode, the execution of the program can be
altered using the Debug toolbar. Note that stepping
through the code uses one of the two available hardware
breakpoints.
13100-025

8.

Figure 27. Elves

Figure 25. Debug Toolbar
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CM3WSD
CM3WSD.exe is an application that can download hex files to
the ADuCM310 over the UART. CM3WSD is installed under
C:\ADuCM310…\Software Tools\CM3WSD\CM3WSD.exe.
To use this application, the device must be in serial download
mode. Enter serial download mode by pressing the
SERIAL_DOWNLOAD button, which is connected to P2.3 on
the ADuCM310, and then by resetting the device.

13100-028

For details of the Cortex-M3 based ADuCxxx serial download
protocol used by CM3WSD, see the AN-1160 Application Note.

Figure 28. CM3WSD

ESD Caution
ESD (electrostatic discharge) sensitive device. Charged devices and circuit boards can discharge without detection. Although this product features patented or proprietary protection
circuitry, damage may occur on devices subjected to high energy ESD. Therefore, proper ESD precautions should be taken to avoid performance degradation or loss of functionality.
Legal Terms and Conditions
By using the evaluation board discussed herein (together with any tools, components documentation or support materials, the “Evaluation Board”), you are agreeing to be bound by the terms and conditions
set forth below (“Agreement”) unless you have purchased the Evaluation Board, in which case the Analog Devices Standard Terms and Conditions of Sale shall govern. Do not use the Evaluation Board until you
have read and agreed to the Agreement. Your use of the Evaluation Board shall signify your acceptance of the Agreement. This Agreement is made by and between you (“Customer”) and Analog Devices, Inc.
(“ADI”), with its principal place of business at One Technology Way, Norwood, MA 02062, USA. Subject to the terms and conditions of the Agreement, ADI hereby grants to Customer a free, limited, personal,
temporary, non-exclusive, non-sublicensable, non-transferable license to use the Evaluation Board FOR EVALUATION PURPOSES ONLY. Customer understands and agrees that the Evaluation Board is provided
for the sole and exclusive purpose referenced above, and agrees not to use the Evaluation Board for any other purpose. Furthermore, the license granted is expressly made subject to the following additional
limitations: Customer shall not (i) rent, lease, display, sell, transfer, assign, sublicense, or distribute the Evaluation Board; and (ii) permit any Third Party to access the Evaluation Board. As used herein, the term
“Third Party” includes any entity other than ADI, Customer, their employees, affiliates and in-house consultants. The Evaluation Board is NOT sold to Customer; all rights not expressly granted herein, including
ownership of the Evaluation Board, are reserved by ADI. CONFIDENTIALITY. This Agreement and the Evaluation Board shall all be considered the confidential and proprietary information of ADI. Customer may
not disclose or transfer any portion of the Evaluation Board to any other party for any reason. Upon discontinuation of use of the Evaluation Board or termination of this Agreement, Customer agrees to
promptly return the Evaluation Board to ADI. ADDITIONAL RESTRICTIONS. Customer may not disassemble, decompile or reverse engineer chips on the Evaluation Board. Customer shall inform ADI of any
occurred damages or any modifications or alterations it makes to the Evaluation Board, including but not limited to soldering or any other activity that affects the material content of the Evaluation Board.
Modifications to the Evaluation Board must comply with applicable law, including but not limited to the RoHS Directive. TERMINATION. ADI may terminate this Agreement at any time upon giving written notice
to Customer. Customer agrees to return to ADI the Evaluation Board at that time. LIMITATION OF LIABILITY. THE EVALUATION BOARD PROVIDED HEREUNDER IS PROVIDED “AS IS” AND ADI MAKES NO
WARRANTIES OR REPRESENTATIONS OF ANY KIND WITH RESPECT TO IT. ADI SPECIFICALLY DISCLAIMS ANY REPRESENTATIONS, ENDORSEMENTS, GUARANTEES, OR WARRANTIES, EXPRESS OR IMPLIED, RELATED
TO THE EVALUATION BOARD INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTY OF MERCHANTABILITY, TITLE, FITNESS FOR A PARTICULAR PURPOSE OR NONINFRINGEMENT OF INTELLECTUAL
PROPERTY RIGHTS. IN NO EVENT WILL ADI AND ITS LICENSORS BE LIABLE FOR ANY INCIDENTAL, SPECIAL, INDIRECT, OR CONSEQUENTIAL DAMAGES RESULTING FROM CUSTOMER’S POSSESSION OR USE OF
THE EVALUATION BOARD, INCLUDING BUT NOT LIMITED TO LOST PROFITS, DELAY COSTS, LABOR COSTS OR LOSS OF GOODWILL. ADI’S TOTAL LIABILITY FROM ANY AND ALL CAUSES SHALL BE LIMITED TO THE
AMOUNT OF ONE HUNDRED US DOLLARS ($100.00). EXPORT. Customer agrees that it will not directly or indirectly export the Evaluation Board to another country, and that it will comply with all applicable
United States federal laws and regulations relating to exports. GOVERNING LAW. This Agreement shall be governed by and construed in accordance with the substantive laws of the Commonwealth of
Massachusetts (excluding conflict of law rules). Any legal action regarding this Agreement will be heard in the state or federal courts having jurisdiction in Suffolk County, Massachusetts, and Customer hereby
submits to the personal jurisdiction and venue of such courts. The United Nations Convention on Contracts for the International Sale of Goods shall not apply to this Agreement and is expressly disclaimed.
©2015 Analog Devices, Inc. All rights reserved. Trademarks and
registered trademarks are the property of their respective owners.
UG13100-0-6/15(0)
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