Evaluation Board for SPI®-/I2C®-Compatible,
10-Bit Digital Temperature Sensor and Quad DAC

EVAL-ADT7316EB
ADT7316 FEATURES

PRODUCT DESCRIPTION

ADT7316: Four 12-bit DACs
ADT7317: Four 10-bit DACs
ADT7318: Four 8-bit DACs
Buffered voltage output
Guaranteed monotonic by design over all codes
10-bit temperature-to-digital converter
Temperature range: −40°C to +120°C
Temperature sensor accuracy of ±0.5°C
Supply range: 2.7 V to 5.5 V
DAC output range: 0 V to 2 VREF
Power-down current: 1 μA
Internal 2.28 VREF option
Double-buffered input logic
Buffered/unbuffered reference input option
Power-on reset to 0 V
Simultaneous update of outputs (LDAC function)
On-chip rail-to-rail output buffer amplifier
I2C®-, SMBus-, SPI®-, QSPI™-, MICROWIRE™-, and
DSP-compatible, 4-wire serial interface
SMBus packet error checking (PEC) compatible
16-lead QSOP package

The ADT7316 evaluation board allows the ADT7316 digital
temperature sensor and quad DAC to be quickly and easily
evaluated using a personal computer. Using the evaluation
board and its accompanying software, the ADT7316 evaluation
board can be interfaced to any personal computer running
Microsoft® Windows® XP/2000 or later, via one of the
computer's USB ports.
The two other parts in the family, the ADT7317 and ADT7318,
differ only in that they have 10-bit DACs and 8-bit DACs
respectively. The evaluation board can be used to emulate the
ADT7317 by setting the two LSBs of the DACs to zero, and for
the ADT7318 by setting the four LSBs of the DACs to zero.
The evaluation board allows all the input and output functions
of the ADT7316 to be exercised without the need for external
components. The software allows control and monitoring of the
internal registers for the ADT7316.

PACKAGE CONTENTS
The evaluation board package contains the following items:
• This document

ADT7316 APPLICATIONS

• The ADT7316 evaluation board

Portable battery-powered instruments
Personal computers
Telecommunications systems
Electronic test equipment
Domestic appliances
Process control

• Evaluation software on CD-ROM
• USB cable
Note: Devices with date codes earlier than 0529 have an internal
reference voltage of 2.25 V.
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DIGITAL PICTURE
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.
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PARTS DESCRIPTION
This section gives a brief description of the ADT7316/
ADT7317/ADT7318 and the system overview. Further
information can be found in the ADT7316/ADT7317/ADT7318
data sheet located at www.analog.com.
The ADT7316/ADT7317/ADT7318 combine a 10-bit
temperature-to-digital converter and a quad 12-/10-/8-bit DAC,
respectively, in a 16-lead QSOP. This includes a band gap
temperature sensor and a 10-bit ADC to monitor and digitize
the temperature reading to a resolution of 0.25°C.

The ADT7316/ADT7317/ADT7318 operate from a single 2.7 V
to 5.5 V supply. The output voltage of the DAC ranges from 0 V
to 2 VREF, with an output voltage settling time of typically 7 ms.
The ADT7316/ADT7317/ADT7318 provide two serial interface
options, a 4-wire serial interface that is compatible with SPI,
QSPI, MICROWIRE, and DSP interface standards, and a 2-wire
SMBus/I2C interface. The devices feature a standby mode that is
controlled via the serial interface.
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EVALUATION BOARD HARDWARE
The ADT7316 evaluation board contains the following main
components:

MINI-B USB CONNECTOR J4

• ADT7316 IC, U1

Table 1. J4 Connections

• USB microcontroller, U12

J4 Pin
1
2
3
4
5

The connections to J4 are shown in Table 1.

• Analog switches
• Interrupt LED, D1
• Power LED, D7
• Temperature sensor, Q1

Mini-B Function
+5 volts
−Data
+Data
Key (not used; connected to ground)
Ground

• Connector for USB interface, J4

The USB microcontroller, U12, handles the rest of the
communication between the Mini-B plug and the evaluation
board.

• DAC output connector, J2

DAC OUTPUT CONNECTOR J2

• VREF input connector, P1

The output of any one of the four DACs (selected by the
software) is available on this connector.

• Bargraph driver and LED bargraph, U7/U8

• LDAC push button, S2

USING THE HARDWARE

VREF INPUT CONNECTOR P1

The hardware is extremely simple to use. Make sure the software is
installed before connecting the evaluation board to a USB port on
the PC using the USB A to Mini-B cable provided. No external
power supply is required.

An external reference voltage from 0.25 V to VDD can be
connected to P1.

TEST POINTS
Various system logic signals and the individual DAC outputs
are available at the test points on the board.
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Typical, Compact, or Custom Installation

EVALUATION BOARD SOFTWARE
The software allows the functions of the ADT7316 to be
controlled from a PC via an easy-to-use interface operating with
Windows XP/2000 or higher. The contents of the device's
internal registers can be read or altered through a user friendly
interface, while the Visual Display window gives a graphical
display of temperature and voltage and allows the
overtemperature limit to be altered using a “slider” control.

You are now given the option to choose a typical, compact, or
custom installation of the software. Select the desired option,
and then click Next.
If Custom is selected, a dialog box appears allowing individual
components to be installed. Select and/or deselect any
components you want or do not want to install, and then click
Next.
If Typical or Compact installation is selected, the Select
Program Folder dialog box appears. This allows you to select
the program folder to which program icons are added. Select
the desired folder and click Next.

INSTALLING THE SOFTWARE
Follow these steps to install the ADT7316 evaluation software.
1. Insert the CD-ROM into the CD-ROM drive.
2. Click Start, and then click Run.

InstallShield now installs the program files to the selected
folders.

3. Type X:ADT7316Eval v2.0.2.exe where “X” is the letter of
your CD-ROM drive.

You must restart your computer to begin using the software. To
restart your computer, click Yes. If you do not want to use the
software immediately, click No.

4. Click OK.
Alternatively, you can run Windows Explorer or My
Computer, select the CD-ROM drive, and then double-click
the ADT7316Eval v2.0.2.exe file.

Click Finish to complete the installation.

Existing Software Installation

5. Extract the files needed to install the software and start the
InstallShield Wizard as shown in Figure 2.

If an existing version of the software is found during
installation, you can modify the installation by adding or
removing components, repair the installation by replacing
existing files with ones from the CD-ROM (useful if a file has
been corrupted), or uninstall the entire software package.

05886-005

Select the desired option and click Next. If Modify is selected,
you can add or remove components. If Repair is selected, all of
the installed files are replaced with new files from the CDROM. If Remove is selected, you are prompted to confirm the
complete removal of the software. Click OK to confirm removal
of the software. During removal of the software, you may need
to confirm removal of some files.

Figure 2. InstallShield Wizard Start-Up Screen

6. Click Next to continue the installation.
Various installation options are available, depending on
whether a version of the software is already installed. If this is
a new installation, a license agreement appears. Click Yes to
accept the agreement and continue with the installation. If
there is an existing installation, refer to the Existing Software
Installation section.

Caution: These files may be in use by other Analog Devices
software. If no other Analog Devices software is installed on the
system, it is safe to delete them. To remove all shared files
without further prompting, select Don't display this message
again and then click Yes.
Click Finish to complete the installation procedure.

7. To install the software in the default folder shown, click Next.
Otherwise, click Browse and choose a different folder; then,
select the folder in which to install the program and click OK.
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Table 2. Icon Functions

USING THE SOFTWARE
When using the software, first ensure that the evaluation board
is powered up and connected to the parallel printer port.

Icon

To start the software, click Start > All Programs > Analog
Devices > ADT7316 Evaluation Software > ADT7316
Evaluation Software.
The software searches for the evaluation board and initializes it,
as shown in Figure 3.

Function
Allows data to be logged and saved. You can also use
the File menu to select this function.
Sets up interrupts and limits. You can also use the
Device menu to select this function.
Displays a tree of the device registers. You can also use
the View menu to select this function.
Displays graphs of temperature and voltage. You can
also use the View menu to select this function.
Allows the device to be configured. You can also use the
Settings menu to select this function.
Allows the DAC outputs to be adjusted. You can also
use the Settings menu to select this function.

Multiple windows for the previous software functions can be
open and active simultaneously. The Window menu shows
which window is on top and allows any window to be brought
to the front.

05886-006

Configuration

Figure 3. ADT7316 Found

Click the Configuration icon to access the Configuration
dialog box. This dialog box allows you to set up the AD7316. It
consists of a set of four tabbed pages that allow various
functions of the device to be configured.

05886-007

If the evaluation board is not found, the following message
appears.

05886-009

Figure 4. ADT7316 Not Found

If this happens, check that the evaluation board is connected
correctly, ensure that S1 is set in the correct position and D1 is
lit, and then try again.
At the top of the program window is a series of menus and
icons.

Figure 6. Device Options Tab

The Device Options tab allows you to select/clear the following
options:
• Monitoring Enabled

05886-008

• Power Down Enabled

Figure 5. Menu and Icon Bar

These can be used to access the various functions of the
software.

• Averaging Disabled
• Interrupt Enabled
• Active Low INT Polarity
• Enable SPI Interface (Note that if SPI interface is enabled, to
switch back to I2C interface it is necessary to exit the
software, disconnect the board, and start again.)
• Select LDAC
• ADC Clock (1.4 kHz or 22.5 kHz)
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EVAL-ADT7316EB

Figure 7. DAC Options Tab

Figure 9. Reference Tab

The DAC Options tab selects the output range for each DAC
(0 V to VREF or 0 V to 2 VREF). It allows the thermal voltage
function of the device to be configured, where the ADT7316
operates as a temperature-to-voltage converter, with DAC A
controlled by the on-chip temperature sensor and DAC B
controlled by the external temperature sensor. The temperature
corresponding to 0 V output can be set by adjusting the analog
offset for each channel, and the resolution for the thermal
voltage function can be set to 8 bits or 10 bits.

The Reference tab features a check box that toggles the internal
2.28 V reference for all four DACs, or an external reference
connected to P1. VREF is limited by the VDD of the ADT7316 so a
value exceeding this (3.3 V) should not be applied to the VREF
Connector P1 (or a half of VDD when 0 V to 2 VREF is selected on
the DAC Options tab). If an external reference voltage is used,
its value should be specified in the box provided. This is to
allow the DAC value to be scaled correctly.

Register Map Access

05886-012

Click the
icon or use the View menu to select the Register
Map Access dialog box.

The LDAC Options tab selects how the DACs are updated.
They can be updated manually from the LDAC pin by pressing
S2, when the MSBs are written to one of the DACs (three
different options available), or from the LDAC register. If the
LDAC register is selected, the LDAC Generation buttons
(located on the right side of the tab) are active. Click one of
these buttons to update the corresponding DAC.

05886-013

Figure 8. LDAC Options Tab

Figure 10. Register Map Access Dialog Box

This dialog box allows the contents of individual registers to be
viewed, and those registers that are read/write can have their
contents changed. The Register Map tree on the left shows the
registers arranged by function. To expand or contract a branch
of the tree, double-click the green label. Double-click the red
label or click the + symbol to expand the tree further. To select
an individual register, click the blue label.
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DAC Control

The name of the register, its address, and its contents in
hexadecimal, decimal, and binary format are displayed. The
register contents can be read by clicking Read, or set to
continuous reading by selecting Continuous Read. Those
registers that are read/write can have their contents changed by
clicking individual bits of the binary display to toggle them, or
by entering a decimal or hex value in the Read/Write section
and clicking Write.

Click the
icon or use the Device menu to access the DAC
Control dialog box.

Graphing

05886-015

Click the
icon or use the View menu to access the Graphing
dialog box.

05886-014

Figure 12. DAC Control Dialog Box

Figure 11. Graphing Dialog Box

The DAC Control dialog box allows the individual DACs to be
controlled manually without having to manipulate the DAC
registers directly. A DAC can be selected and controlled using
the slider.

This dialog box allows the internal or external temperature,
VDD, or the DAC outputs, to be displayed as a rolling graph.
Measurement limits can also be displayed. To view the graphic
data in more or less detail, move the arrow pointers on the Xaxis and Y-axis to zoom in or zoom out.
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This dialog box allows you to set which inputs are logged, as
well as the log interval. Once this has been set up, click Start
Logging and the Open dialog box appears.

Setting Interrupts and Limits

05886-018

05886-016

Click the
icon or use the Device menu to access the
Interrupt Settings dialog box.

Figure 13. Interrupt Settings Dialog Box
Figure 15. Open Dialog Box

The six interrupt sources are shown on the left of the dialog
box. When an interrupt is asserted, the corresponding green
status indicator turns red. Interrupts can be masked by selecting
the box next to the name of the interrupt source. High and low
limits for the two measured parameters (internal temperature
and VDD) can be set using the slider controls.

Data Logging

After selecting an existing file or typing a new file name, click
Open to begin data logging. To stop data logging, click Stop
Logging.
Note that graphing must be running during data logging, or the
data does not change.

icon or use the File menu to access data logging.

05886-017

Click the

You can use this dialog box to open an existing log file or create
a new log file by typing in a new file name.

Figure 14. Logging/Save/Recall Dialog Box
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SCHEMATICS AND SILKSCREEN

Figure 16. Evaluation Board Schematic
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Figure 17. ADT7316 Evaluation Board Schematic (Continued)
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Figure 18. ADT7316 Evaluation Board Schematic (Continued)

Figure 19. ADT7316 Evaluation Board Silkscreen
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ORDERING INFORMATION
BILL OF MATERIALS
Table 3. Parts List for EVAL-ADT7316EB Evaluation Board
Name
C1
C2
C3
C4
C5
C6
C7
C8
C9
C10
C11
C12
C14
C15
C16
C17
D1
D2
D3
D4
D5
D6
DIN
DOUT
GND1
GND2
GND3
GND4
INT
J1
J2
J3
P1
Q1
Q2
R1
R2
R3
R4
R5
R6
R8
R9
R10
R11
R12
R13
R14
R15

Part Type
CAP+
CAP
CAP
CAP
CAP+
CAP
CAP
CAP
CAP
CAP
CAP
CAP
CAP
CAP+
CAP
CAP
LED
LED
SD103C
SD103C
SD103C
SD103C
TESTPOINT
TESTPOINT
TESTPOINT
TESTPOINT
TESTPOINT
TESTPOINT
TESTPOINT
USB
CON\POWER
CON\POWER4
SMB
2N3906
BC807-40LT1
RES
RES
RES
RES
RES
RES
RES
RES
RES
RES
RES
RES
RES
RES

Value
10 uF
0.1 uF
0.1 uF
0.1 uF
10 uF
0.1 uF
0.1 uF
0.1 uF
0.1 uF
0.1 uF
0.1 uF
0.1 uF
0.1 uF
47 uF
0.1 uF
0.1 uF

Tolerance

1K
2K2
4K7
2K2
10K
1K
2K2
2K2
2K2
2K2
2K2
2K2
3K9
1K2

1%
1%
1%
1%
1%
1%
1%
1%
1%
1%
1%
1%
1%
1%

Description
10 V tantalum capacitor
16 V X7R multilayer ceramic capacitor
16 V X7R multilayer ceramic capacitor
16 V X7R multilayer ceramic capacitor
10 V tantalum capacitor
16 V X7R multilayer ceramic capacitor
16 V X7R multilayer ceramic capacitor
16 V X7R multilayer ceramic capacitor
16 V X7R multilayer ceramic capacitor
16 V X7R multilayer ceramic capacitor
16 V X7R multilayer ceramic capacitor
16V X7R multilayer ceramic capacitor
16 V X7R multilayer ceramic capacitor
10 V tantalum capacitor
16 V X7R multilayer ceramic capacitor
16 V X7R multilayer ceramic capacitor
Red SMD light emitting diode
Green SMD light emitting diode
Schottky diode
Schottky diode
Schottky diode
Schottky diode
Red testpoint
Red testpoint
Black testpoint
Black testpoint
Black testpoint
Black testpoint
Red testpoint
USB_RECPTACLE_B
2-pin terminal block (5 mm pitch)
4-pin terminal block (5 mm pitch)
50 Ω SMB jack
PNP bipolar transistor
Low power bipolar transistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
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Name
R16
R17
R18
R19
R21
R22
R23
R24
R25
R26
R27
R28
R29
S1
S2
SCL
SCLK
SDA
U1
U2
U3
U5
U6
U7
U8
U9
U10
VOUTA
VOUTB
VOUTC
VOUTD
Y1

Part Type
RES
RES
RES
RES
RES
RES
RES
RES
RES
RES
RES
RES
RES
SW-SPDT-SLIDE
SW-PUSH-SMD
TESTPOINT
TESTPOINT
TESTPOINT
ADT7316
ADG715
ADG715
24LC64
AD780
LM3914
LED_BAR_ARRAY
CY7C68013-CSP
ADP3303-3.3
TESTPOINT
TESTPOINT
TESTPOINT
TESTPOINT
XTAL-CM309S

Value
2K2
22K
2K2
2K2
22K
2K2
2K2
2K2
2K2
2K2
2K2
2K2
10K

Tolerance
1%
1%
1%
1%
1%
1%
1%
1%
1%
1%
1%
1%
1%

Description
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
0.063 W resistor
SPDT slide switch
SMD push button switch (sealed 6 mm x 6 mm)
Red testpoint
Red testpoint
Red testpoint
Temperature sensor
Octal SPST switch
Octal SPST switch
Voltage reference
LED bar array

24 MHz

Red testpoint
Red testpoint
Red testpoint
Red testpoint
Plastic SMD crystal

ORDERING GUIDE
Model
EVAL-ADT7316EB

Description
Evaluation Board

ESD CAUTION
ESD (electrostatic discharge) sensitive device. Electrostatic charges as high as 4000 V readily accumulate on
the human body and test equipment and can discharge without detection. Although this product features
proprietary ESD protection circuitry, permanent damage may occur on devices subjected to high energy
electrostatic discharges. Therefore, proper ESD precautions are recommended to avoid performance
degradation or loss of functionality.
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NOTES
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