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General Description
The MAX11259PMB peripheral module (Pmod™) provides 
the necessary hardware to interface to the MAX11259, a 
24-bit, 6-channel, 64ksps, integrated PGA delta-sigma 
ADC to any system that utilizes Pmod-compatible expan-
sion ports configurable for I2C communication. The 
peripheral module includes a graphical user interface 
(GUI) that provides communication from the target device 
to the PC through the USB2PMB2#. The peripheral mod-
ule can operate in multiple modes:
1)	 Using USB2PMB2# Adapter: In “standalone” mode, 

the peripheral module is connected to the PC via a  
USB2PMB2# adapter board and performs a subset of 
the complete peripheral module functions with limita-
tions for sample rate, sample size, and no support for 
coherent sampling.

2)	 User-Supplied I2C Mode: The peripheral module pro-
vides a 12-pin Pmod-style header for user-supplied I2C 
interface to connect the signals for SCL, SDA, RSTB, 
and RDYB.

The peripheral module includes Windows XP®, Windows® 
7, and Windows 8.1-compatible software for exercising 
the features of the IC. The peripheral module GUI allows 
different sample sizes, adjustable sampling rates, internal 
or external reference options, and graphing software that 
includes the FFT and histogram of the sampled signals. 
The peripheral module can be powered by a local +3.3V 
supply and comes installed with a MAX11259AWX+ in a 
36-bump WLP package. 

Features and Benefits
●● Various Sample Sizes and Sample Rates
●● Time Domain, Frequency Domain, and Histogram 

Plotting 
●● On-Board Voltage Reference (MAX6072)
●● Proven PCB Layout
●● Fully Assembled and Tested
●● Windows XP-, Windows 7-, and Windows 

8.1-Compatible Software

Pmod is a trademark of Digilent Inc.
Windows and Windows XP are registered trademarks and reg-
istered service marks of Microsoft Corporation.  

Ordering Information appears at end of data sheet.
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Quick Start
Required Equipment

●● MAX11259PMB
●● +3.3V (50mA) for the MAX11259PMB
●● Micro-USB cable
●● USB2PMB2# adapter
●● Function generator (optional)
●● Windows XP, Windows 7, or Windows 8.1 PC with a 

spare USB port

Note: In the following section(s), software-related items 
are identified by bolding. Text in bold refers to items direct-
ly from the EV system software. Text in bold and under-
line refers to items from the Windows operating system.

Procedure
The peripheral module is fully assembled and tested. 
Follow the steps below to verify board operation:
1)	 Visit www.maximintegrated.com/evkitsoftware to  

download the latest version of the peripheral mod-
ule  software, MAX11253_54_59EVkitSetupV1.12.zip. 
Save the peripheral module software to a temporary 
folder and uncompress the ZIP file.

2)	 Install the peripheral module software and 
USB driver on your computer by running the 
MAX11253_54_59EVkitSetupV1.12.exe program in-
side the temporary folder. The program files are cop-
ied to your PC and icons are created in the Windows  
Start | Programs menu. At the end of the installation 
process the installer will launch the installer for the 
FTDIChip CDM drivers.

3)	 Verify that all jumpers are in their default positions for 
the peripheral module board (Table 1).

FILE DECRIPTION

MAX11253_54_59EvkitSetupV1.12.exe Application Program 
(GUI)

System Block Diagram

MAX11259PMB Peripheral Module Files

http://www.maximintegrated.com/evkitsoftware
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4)	 Connect the PC to the peripheral module via the 
USB2PMB2 adapter board using a micro-USB cable.

5)	 Start the peripheral module software by opening its 
icon in the Start | Programs menu. The peripheral 
module software appears as shown in Figure 1. From 
the Device menu select Standalone. Verify that the 
lower left status bar indicates the EV kit hardware is 
Connected.

6)	 Connect the positive terminal of the function genera-
tor to the CH0+ (J11-1) test point on the peripheral 
module. Connect the negative terminal of the function 
generator to the CH0- (J11-2) test point on the periph-
eral module.

7)	 Configure the signal source to generate a 100Hz, 
1VP-P sinusoidal wave with +1V offset.

8)	 Turn on the function generator.

9)	 In the configuration group of the Device menu, select 
Channel 0 and click Convert in the serial interface 
menu.

10)	 Click on the Scope tab.
11)	 Check the Remove DC Offset checkbox to remove 

the DC component of the sampled data.
12)	 Click the Capture button to start the data analysis.
13)	 The peripheral module software appears as shown in 

Figure 1.
14)	 Verify that the frequency, which is displayed on the 

right, is approximately 100Hz. The scope image has 
buttons in the upper right corner that allow zooming 
in to detail.
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Table 1. MAX11259PMB Board Jumper Settings 

*Default configuration

HEADER JUMPER 
POSITION DESCRIPTION

JMP1/JMP2

1-2*/1-2* Select address 0x30

1-2/1-3 Select address 0x31

1-2/1-4 Select address 0x33

1-3/1-2 Select address 0x34

1-3/1-3 Select address 0x35

1-3/1-4 Select address 0x37

1-4/1-2 Select address 0x3C

1-4/1-3 Select address 0x3D

1-4/1-4 Select address 0x3F

J2
1-2 Use MAX6072 VREF/2 as VCOM

2-3* Use GND as VCOM

J4
1-2* Select +3.3V for DVDD

Open Select user-provided supply for DVDD at J4-1

J5
1-2* Select +3.0V for AVDD

Open Select user-provided supply for DVDD at J5-1

J6
1-2* Select GND for AVSS

Open Select user-provided supply for AVSS at J6-1

J7
Open* Use internal 1.8V subregulator if DVDD ≥ 2.0V

1-2 Use DVDD for internal logic if DVDD ≤ 2.0V

J8
1-2* Select VREF from the on-board MAX6072 as the voltage reference

2-3 Select AVDD as the voltage reference
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General Description of Software
The main window of the peripheral module software con-
tains seven tabs: Configuration, Scope, DMM, Histogram, 
FFT, Scan Mode, and Registers. The Configuration tab 
provides control for the ADC configuration including cali-
bration and data capture. The other six tabs are used for 
evaluating the data captured by the ADC.

Configuration Tab
The Configuration tab provides an interface for selecting 
and configuring the ADC from a functional perspective. 
Select the desired Device in the drop-down menu and the 
corresponding properties of the device are displayed includ-
ing Channel number, Sample Rate, Number of Samples, 
Reference Voltage, Sequencing Mode, Calibration, 
GPO/GPIO selection, Input Path (Direct or internal 
PGA), Delta-Sigma Modulator type selection for different 
Data Format and Conversion Mode, Serial Interface 
function (Convert, and Read All), Power setting (NOP, 
Power Down, and Standby), Reset Registers, and RSTB 

Reset, Clock/SYNC (Internal or External Clock, and 
Disable or Enable SYNC Mode), and Other for Disable or 
Enable Current Sink/Source and CAPREG LDO.
The sample settings are available on the left of the config-
uration menu, which allow the user to select the Channel, 
Sample Rate, and Number of Samples.
The Read Data and Status information is displayed on 
the right, which shows the data in both voltage and Hex, 
the sample rate, and power state for the selected chan-
nel. In addition, if there are any errors, the indicator lights 
will turn red.

Channel Selection
To select the desired channel among the six available 
channels, click Channel # drop-down menu at the top left 
and select the desired channel from 0 to 5. The default 
selection is Channel 0.

Figure 1. Peripheral Module Software (Configuration Tab)
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Sample Rate (SPS)
To select the desired data rate for single-cycle mode from 
50sps to 12800sps and for continuous mode data rate 
from 1.9sps to 64000sps, choose the Sample Rate (SPS) 
from the drop-down menu below the Channel # selection.

Reference Voltage
There are two different reference voltages available on 
board: MAX6072AUT18+ (2.5V), and AVDD (+3.0V). To 
select 2.5V, connnect J8-1 to J8-2. To select 3.0V, con-
nect J8-2 to J8-3.

Sequencer Mode
To change the sequencer mode, click the Sequence 
Mode selection below the Sequencing menu and select 
Mode 1, 2, or 3 as desired. Check the GPO Sequencer 
Mode box to enable GPO/GPIO function in mode 3. In 
addition, check the Enable box to enable the MUX and 
GPO Delay. Choose the desired delay in microseconds 
by clicking on the + or – buttons.

ADC Calibration
Two types of software calibration for offset and gain are 
available: Self calibration and system calibration.
The primary mode for calibration is using the drop-down 
list to select a calibration mode, followed by clicking the 
Calibrate button. The checkboxes for Self Offset, Self 
Gain, System Offset, and System Gain allow for the 
user to enable or disable the calibration values. The cali-
bration values can also be changed manually by entering 
a hex value in the numeric box.

GPO/GPIO
To select GPO or GPIO ports, choose the option under the 
GPO/GPIO drop-down menu and check the Enable box.

Input Path
Select Direct under the Input Path drop-down menu to 
bypass the internal amplifiers and apply the analog input 
signals directly to the MAX11259PMB inputs at J11.
Select PGA under the Input Path drop-down menu to use 
the internal programmable gain amplifiers.

Delta-Sigma Modulator
To select the desired data format, click the Data Format 
drop-down menu under the Delta-Sigma Modulator 
section and choose either Bipolar or Unipolar with two’s 
complement or offset binary options.
Three conversion modes are provided: Continuous, 
Single Cycle, and Single Continuous. Click the 
Conversion Modes drop-down menu under the Delta-

Sigma Modulator section to select the desired conver-
sion mode.

Serial Interface
To starting converting, click the Convert button under 
the Serial interface section. To read all registers, click the 
Read All button.

Power
The MAX11259PMB peripheral module features three 
power-down states: Normal Operating Power (NOP), 
Power down, and Standby. Select the desired power 
state by clicking the drop-down menu under the Power 
section.
To reset the configuration settings back to default values, 
press the Reset Registers button.
To exercise the power-on reset feature, click the RSTB 
button.

Clock/SYNC
The internal clock mode is set at default condition. To 
use user-supplied external clock, select External under 
the Clock/SYNC section and connect the external clock 
signal to J9-1, GPIO0/CLK pin. In addition, the Sync 
mode can be enabled or disabled by clicking the drop-
down menu under this Clock/SYNC section and connect 
the external sync signal to J9-2, GPIO1/SYNC. The Sync 
signal should be provided externally.

Other
To enable (J7 open) or disable (J7 installed and VDDVD ≤ 
2.0V) the internal CAPREG LDO for digital and I/O sup-
ply, select this option from the drop-down menu under 
the Other section. Additionally, Current Sink/Source can 
also be disabled or enabled under this section.

Read Data and Status
The Read Data and Status on the far right hand side of 
this Configuration menu depicts the received data and 
status of the device such as the selected channel, data 
rate, sample rate, and power state. Click the Read Data 
and Status button to view the updated status.
To save a configuration, select Save ADC Config As… in 
the File menu. This saves all the ADC register values to a 
XML file. To load a configuration, select Load ADC Config 
in the File menu. When the XML file is loaded, all the reg-
ister values in the file are written to the ADC.
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Scope Tab
The Scope tab sheet is used to capture data and display it 
in the time domain. The desired Channel #, Sample Rate, 
Number of Samples, Display Unit, Average Samples, 
and Resolution Selection can also be set in this tab if 
they were not appropriately adjusted in other tabs. The 
Display Unit drop-down list allows counts in LSB and 
voltages in V, mV, or µV. Once the desired configuration is 

set, click on the Capture button. The right side of the tab 
sheet displays details of the waveform, such as average, 
standard deviation, maximum, minimum, and fundamen-
tal frequency as shown in Figure 2.
To save the captured data to a file, select Options > Save 
Graph > Scope. This saves the setting on the left and the 
data captured to a CSV file.

Figure 2. Peripheral Module Software (Scope Tab)
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DMM Tab
The DMM tab sheet provides the typical information as a 
digital multimeter. Once the desired configuration is set, 

click on the Capture button. Figure 3 displays the results 
shown by the DMM tab when a 1.5V signal is applied to 
AIN0+ and 1.0V to AIN0-.

Figure 3. Peripheral Module Software (DMM Tab)
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Histogram Tab
The Histogram tab sheet is used to show the histogram 
of the data. Sample rate and number of samples can also 
be set in this tab if they were not appropriately adjusted 
in other tabs. Once the desired configuration is set, click 
on the Capture button. The right side of the tab sheet 
displays details of the histogram such as average, stan-
dard deviation, maximum, minimum, peak-to-peak noise, 
effective resolution, and noise-free resolution as shown 
in Figure 4.

The histogram tab is enabled at default. Using the 
histogram will slow down the GUI response. To disable it, 
check the Disable Histogram box.
To save the histogram data to a file, go to Options > Save 
Graph > Histogram. This saves the setting on the left 
and the histogram data captured to a CSV file.

Figure 4. Peripheral Module Software (Histogram Tab)
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FFT Tab
The FFT tab sheet is used to display the FFT of the data. 
The Sample Rate, Number of Samples, Resolution and 
Window Function type can be set as desired. To calcu-
late the Adjusted Input Signal frequency for Coherent 
Sampling, enter the Input Signal frequency in Hertz and 
push the Calculate button. Once the preferred configura-
tion is set, click on the Capture button. The right side of 
the tab displays the performance based on the FFT, such 
as fundamental frequency, SNR, SINAD, THD, SFDR, 
ENOB, and Noise Floor as shown in Figure 5.

To save the FFT data to a file, go to Options > Save 
Graph > FFT. This saves the setting on the left and the 
FFT data captured to a CSV file.
When coherent sampling is needed, this tab allows 
the user to calculate the external clock frequen-
cy applied to the board. Adjust the input frequency 
of the low-jitter clock to the value as shown in the 
Adjusted Master Clock (Hz) and apply it to the EV KIT  
EXT_CLK connector. See the Sync Input and Sync Output 
section before using this feature.

Figure 5. Peripheral Module Software (FFT Tab)



Maxim Integrated  │  12www.maximintegrated.com

Evaluates: MAX11259MAX11259PMB Peripheral Module

Figure 6 shows the setup Maxim Integrated uses to 
capture data for coherent sampling.
For coherent FFT evaluation, use the jumper settings 
from Table 1 for proper configurations. The low-jitter 
clock is synchronized with the signal generator at 10MHz 
from the external clock generator. To achieve coherent 

sampling, click on the Calculate button and enter the 
Adjusted Master Clock (Hz) frequency of approximately 
8.192MHz into our low-jitter clock. Timing for all I2C timing 
and sampling rate are based off the system clock.

Figure 6. Peripheral Module Coherent Sampling Setup
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Scan Mode Tab
The Scan Mode tab is used to perform selected data 
conversions and read the converted data.
In the Sequence Setting section at the bottom, set the 
desired sequencer mode (2 or 3) from the Sequence 
Mode drop-down menu and select whether to assert 
the RDYB pin after one channel or after scan com-
pletes options under the RDYB menu. Check the GPO 
Sequencer Mode and Enable boxes as desired. Then 
set the conversion time delay in µs for MUX and GPO by 
clicking on the + or - buttons under the MUX Delay and 
GPO Delay menu, allowing for high impedance source 
networks to stabilize after the channels are selected. 

Finally press the Read All button to view the selected 
settings.
In the Read Data section on top, select the desired unit 
in either LSB or voltage (V, mV, or µV) under the Display 
Unit drop-down menu. Then choose the desired sample 
rate by clicking on the Sample Rate drop-down menu 
under. Finally, click the Scan button to start convert-
ing and press the Read Data button to view the con-
verted data displayed on the right hand side as shown in  
Figure 7.

Figure 7. Peripheral Module Software (Scan Mode Tab)
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ADC Registers Tab
The Registers tab sheet shows the device registers on 
the left. The middle section shows the descriptions of the 
selected register. Click Read All to read all registers and 
refresh the window with the register settings. To write a 
register first select the hex value in the Value column, 
type the desired hex value and press Enter.
The command byte is on the right side of the tab sheet. 
This byte precedes all I2C transactions and is described 
in the IC data sheet. To send a command byte enter a 
hex value in the numeric box and click the Send button. 
The command byte has two different formats includ-
ing Conversion Command and Register Read/Write. 
Select the radio button for the desired mode to see the bit 
description in the table. See Figure 8.

Detailed Description of Hardware
The MAX11259PMB peripheral module provides a proven 
signal path and board layout to demonstrate the perfor-
mance of the MAX11259AWX 24-bit, delta-sigma ADC. 
Included in the peripheral module are digital isolators, 
ultra-low-noise LDOs to all supply pins of the IC, on-board 
reference (MAX6072), and sync-in and sync-out signals for 
coherent sampling.
The USB2PMB2 FTDI controller is provided to allow for 
evaluation in standalone mode, which has limitations 
on maximum sample speed and on sample depth. The 
peripheral module can be used with FPGA to achieve full 
speed and a larger sample depth.
The peripheral module supports a number of different 
devices as listed in Table 2.

Figure 8. Peripheral Module Software (ADC Registers Tab)
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User-Supplied I2C
To evaluate the peripheral module with a user-supplied 
I2C bus, apply the user-supplied I2C signals to J1. Make 
sure the return ground is connected to MAX11259PMB 
ground.

Voltage References
There are two different reference voltages available on 
board: MAX6072 (2.5V), AVDD (3.0V). To select 2.5V, 
connect J8-1 to J8-2. To select 3.0V, connect J8-2 to J8-3.
For user-supplied external references, remove jumper J8 
and connect a reference voltage to J8-2. Measure and 
enter the value of the external reference voltage into the 
Reference Voltage edit box on the Configuration tab of 
the GUI. Table 2 depicts the reference source options.

External DVDD Power Supply
The internal 1.8V regulator can be replaced by an exter-
nal supply in the range of 1.7V to 2.0V. To use external 
DVDD, disable the internal regulator by selecting the 
Disable in the CAPREG LDO drop-down menu in the 
Other section and install J7.

User-Supplied Power Supply
The peripheral module receives power from a single DC 
source of  +3.3V (50mA) through the standard Pmod 
connector, J1, to provide supply to DVDD. The power is 
then regulated to +3.0V supply for AVDD and MAX6072 
voltage reference. See the peripheral module schematic 
pdf for details. Specific voltages can be connected to the 
board, see Table 2 for corresponding jumper positions.

Table 2. Reference Source Options

Table 3. Power Supply to the Board

REF 
SOURCE JUMPER CONNECTION FUNCTION

MAX6072 
(2.5V) J8 1-2 Select U3 

MAX6072

AVDD J8 2-3 Select AVDD

User-
Supplied J8

Open. Connect 
user-supplied 

reference  
to J8-2

Select User-
Supplied 
Reference

POWER JUMPERS
An external +3.3V J1-6
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External Clock For Coherent Sampling
Set the external low jitter clock generator with the value 
calculated by the GUI in the FFT tab. Connect the output 
of the clock generator to GPIO0/CLK pin (J9-1). The 
relationship between fIN, fS, NCYCLES, and MSAMPLES 
is given as follows:

CYCLESIN

S SAMPLES

Nf
 

f M
=

where:
fIN = Input frequency
fS = Sampling frequency
NCYCLES = Prime number of cycles in the sampled set
MSAMPLES = Total number of samples

#Denotes RoHS compliant.

The MAX11259PMB# comes with a MAX11259AWX+ in a 
36-bump WLP package.

PART TYPE

MAX11259PMB# Peripheral Module

USB2PMB2# Munich Adapter Board

MAX11259SYS1# Peripheral Module and Munich 
Adapter Board

Component List, Schematics, and PCB 
Layout Diagrams
See the following links for component information, sche-
matic diagrams, and PCB layout diagrams:

●● MAX11259PMB BOM
●● MAX11259PMB Schematics
●● MAX11259PMB PCB Layout

Ordering Information
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