Get Up and Running with LTspice

Gabino Alonso, Director of Strategic Marketing

The key to most circuit designs is the speed with which you can reach an understanding of your circuit, its correctness, and its limitations, so that you can refine your design and select components before going into the lab to prototype and test. LTspice® is Analog Devices’ high-performance circuit simulation program, which allows you to draft, probe, and analyze the performance of your circuit design. LTspice contains an integrated schematic editor, waveform viewer, and advanced features that are easy to use once you learn some basic commands.

LTspice includes an extensive library of macromodels covering most of ADI’s power management and signal chain products, as well as a library of passive components. LTspice uses proprietary modeling techniques for its macromodels, resulting in fast, accurate simulation results. This is especially important for switch-mode power supply designs, an area where LTspice outperforms many other simulation tools and enables you to iterate your designs in minimal time. Successive simulations allow you to explore the circuit limitations and performance boundaries of your design through minor adjustments, helping to develop your circuit intuition.

LTspice is provided at no cost to our customers and to the engineering community. Do not let its free status dissuade you; it outperforms many simulation solutions in the market and is not hobbled by any arbitrary limits. Consequently, you can create, encapsulate, and abstract complex circuits with confidence that circuit size and hierarchy are only limited by your computer’s resources and your time.

Software Installation and Updates

LTspice software runs on Windows® and Mac® OS X operating systems. Downloadable installation files for LTspice are available at analog.com/LTspice. To keep your software updated with the latest models, software, and examples, it is important to synchronize your release of LTspice. Sync Release is available under the LTspice Tools menu (Figure 1).

Use an Existing Circuit

Drafting a circuit from scratch can be a daunting task when using a new tool. Instead of starting with a blank slate, it is far better to familiarize yourself with LTspice by exploring an existing schematic and reviewing its performance in a simulation. LTspice schematic files are saved with an .asc extension. There are three main sources of LTspice schematics:

- Demonstration circuits available from LTspice.
- Test fixtures installed with LTspice.
- Educational examples installed with LTspice.

Download a Demo Circuit

If you are interested in a specific solution, look through ADI’s extensive collection of LTspice examples in the Demo Circuits section. These examples can also be found through product and evaluation board webpages under Tools & Simulations. Demo circuits are reviewed by applications engineering and provide a solid starting point for most designs. Many are based on available hardware evaluation boards.

To Use an LTspice Demo Circuit:

Find the demo circuit through a product web page or by searching the Demo Circuit database for a part or application. Download the demo circuit .asc file to your local directory and open it.
Get Up and Running with LTspice

If you cannot find a demo circuit for the product you are interested in, there is a test fixture that can act as a starting point for your design.

**Grab a Test Fixture**
Most of Analog Devices’ power management and signal chain products that are modeled in LTspice have an associated predrafted test fixture available. These test fixtures, called jigs, are used by the ADI modeling teams for testing and evaluating device macromodels, and are offered as drafting starting points. Note that test fixtures are not recommended for production use. They have not necessarily been reviewed by factory applications engineers, and many are simplified; they use ideal passive components or they are focused on evaluating how the macromodel handles specific fault conditions. Nevertheless, as a starting point, test fixtures are often better than a blank slate.

**To Open a Jig File for a Device or Component:**
- Open LTspice.
- Choose **File > New Schematic** or press CTRL + N. A blank schematic will appear.
- Choose **Edit > Component** or press F2. The component dialog will appear.

![Search the device you want by typing its name in the text field.](image)

- In the component window, the easiest way to find a device is to type its name in the text box. The list reduces in size as you type, filtered to match your input. Once you see the device of interest in the list, select it and the inactive **Open this macromodel’s test fixture** button becomes active.
- Click **Open this macromodel’s test fixture** button. The schematic for the macromodel’s test fixture appears. Alternatively, you can click **Okay** to insert the model symbol and draw your own schematic.

**Start with an Educational Example**
LTspice includes educational examples designed to help you explore simulations and circuit design. Educational examples are installed along with LTspice, located in `C:\Program Files\LTC\LTspiceXVII\examples\Educational`.

![Educational examples are installed with LTspice.](image)

**Using the Schematic Editor**
LTspice is designed to expedite schematic drafting, but all schematic editors have a learning curve. With LTspice, once you learn the basic menu and the shortcut keys, it is very easy to draft and edit your schematics. All schematic editing commands and components are available under the **Edit** menu or by right-clicking the schematic background.

Drafting a circuit from scratch using the schematic editor is not covered here, but is well documented. Available instructional videos are a good way to learn the basics of drafting a circuit from scratch in LTspice with a few listed in the Additional Resources section at the end of this article.

**Editing Component Attributes**
In most cases, to modify an object’s attributes, right-click the object. Depending on the circuit element, an editor window will appear, where you can change component parameters.

![Resistor component parameters.](image)

Resistors, capacitors, inductors, beads, diodes, bipolar transistors, MOSFET transistors, and JFET transistor circuit components have an associated database of models from which to choose. This extensive library of models for passive components can be leveraged to quickly build or modify a schematic using realistic components. If you cannot find the exact model of a device, you can use a similarly specified model instead and later add a model of the specific device of interest to the component database.
Some components feature advanced options. For instance, the voltage source's basic attributes are shown in Figure 8.

Click Advanced to access the voltage source's additional parametric options, as shown in Figure 9.

Entering Units
When you enter a parametric value in option field, LTspice follows standard notation with the exception of using MEG (or meg) to specify $10^6$. Capital M is used by LTspice as an alternative to m for $10^{-3}$ (milli). See Table 1. Be careful when typing 1F for 1 farad as it incorrectly indicates $1 \times 10^{-15}$ femtofarad. For 1 farad, just enter 1.

### Table 1. Standard Unit Prefixes in LTspice

<table>
<thead>
<tr>
<th>Character</th>
<th>What It Means</th>
</tr>
</thead>
<tbody>
<tr>
<td>T or t</td>
<td>tera $= 10^{12}$</td>
</tr>
<tr>
<td>G or g</td>
<td>giga $= 10^9$</td>
</tr>
<tr>
<td>MEG or meg</td>
<td>Meg $= 10^6$</td>
</tr>
<tr>
<td>K or k</td>
<td>kilo $= 10^3$</td>
</tr>
<tr>
<td>M or m</td>
<td>milli $= 10^{-3}$</td>
</tr>
<tr>
<td>U or u (LTspice replaces with µ)</td>
<td>micro $= 10^{-6}$</td>
</tr>
<tr>
<td>N or n</td>
<td>nano $= 10^{-9}$</td>
</tr>
<tr>
<td>P or p</td>
<td>pico $= 10^{-12}$</td>
</tr>
<tr>
<td>F or f</td>
<td>femto $= 10^{-15}$</td>
</tr>
</tbody>
</table>

### Navigate the Schematic
To navigate the schematic editor, use the mouse and scroll wheel to pan, zoom in, and zoom out in your schematic or use the options under the View menu. Click and drag a schematic to pan. Press the space bar to jump back to a full screen view.

### Add Simulation Commands
Simulation commands for demo circuits, jigs, and educational example files are already defined so that you can run the simulation with no additional editing. LTspice includes simulation commands for transient, linearized small signal ac, dc sweep, noise, dc operating point, and small signal dc transfer function analysis.

### To Insert or Edit a Simulation Command:
Choose Edit Simulation Cmd from the Simulate menu. The Edit Simulation Command dialogue will appear (Figure 10). It includes tabs for each analysis and fields for the associated parameters. More information on these different types of analyses is available in the F1 help files, which can be accessed by pressing F1.

### Run the Simulation
Once you have selected or drafted a schematic, choose Run from the Simulate menu. This generates a netlist file from the schematic editor using the same file name, but with the .net extension. LTspice simulates this netlist. To view the contents of a netlist, choose SPICE Netlist from the View menu.
View Waveforms

Probing Your Schematic
To analyze your circuit, after executing the run command, you can use the cursor to probe the schematic directly or use the Add Trace (or Visible Trace) command under the Plot Settings. This results in the trace appearing in the waveform viewer.

To Plot Ground-Referenced Voltage:
Place the cursor on the wire or node of interest. The cursor image will change to a red voltage probe. Click the wire or node of interest. The voltage displayed is referenced to ground.

To Plot a Current
To plot the current through a component with two-wire connections:
1. Move the cursor over the body of the component.
2. The cursor image will change to a current probe (Figure 14).
3. Click the body of the component.
To plot the current into a pin of a component with more than two connection points:
1. Place the cursor over the pin of interest.
2. The cursor image will change to a current probe.
3. Click the pin of interest.

Navigate the Waveform Viewer
Zooming in the Waveform
In the waveform window, you can use the mouse to zoom in. To zoom into a specific region of the waveform window, drag a box around the region you wish to draw larger (Figure 17).
Taking Quick Measurements

If you draw a box around an area of interest and hold the mouse button down, the size of the box (in the x and y units) is displayed on the lower left corner of the waveform viewer. This enables quick measurements. Minimize the box before releasing the mouse button to prevent zooming in.

Figure 17. Taking a quick measurement.

Deleting Traces

To delete individual traces from the waveform viewer, right-click the label of the trace at the top of the waveform viewer that you want to delete and select Delete this Trace. Alternatively, you can click the waveform viewer to make sure it is the active window, and choose Delete this Trace from the Plot Settings menu (or press F5). The cursor changes to an image of scissors. At the top of the waveform viewer, click the labels of any traces you want removed. Right-click or press Esc to end the delete function.

If you only want to focus on one trace, double-click the wire, node, component, or pin, and all other traces from the waveform viewer will be removed.

You can explore the additional features of the waveform viewer by clicking on the window to make it active and reviewing the options under the Plot Settings menu or by right-clicking the waveform viewer.

Additional Features

LTspice also features other advanced simulations including steady state detection, turn-on transient response, step response, efficiency/power computations, and other advanced analysis options. To learn more about the waveform viewer and/or advanced simulation techniques, please see the following Additional Resources section.

Additional Resources

To learn more about LTspice, visit analog.com/LTspice for technical articles and videos. The following classic videos provide additional foundational learning on using a schematic editor and a waveform viewer.

Schematic Editor

Waveform Viewer

For all general LTspice questions, refer to the help file (press F1) for more details or one of the many online LTspice forums such as EngineerZone® or one of the many LTspice user groups, which provide discussion threads, tutorials, and simulation examples to explore. If you encounter a software bug or device model issues, please email LTspice@analog.com. However, if you have a specific question with regard to a simulation using an ADI device in your application, it would be best to reach out directly to your local field applications engineer for support.

Happy simulations!

* This program is specifically not licensed for use by semiconductor manufacturers in the design, promotion, demonstration, development, or sale of their products. Specific permission must be obtained from Analog Devices for the use of LTspice for these applications.

** ADI device macromodels are implemented using proprietary description languages that are native to LTspice and, as such, will not run on other SPICE platforms.

References


About the Author

Gabino Alonso is currently the director of strategic marketing for the Power by Linear™ Group. Prior to joining ADI, Gabino held various positions in marketing, engineering, operations and education at Linear Technology, Texas Instruments, and California Polytechnic State University. He holds a Master of Science degree in electrical and computer engineering from University of California, Santa Barbara. He can be reached at gabino.alonso@analog.com.