Copyright Information

© 2012 Analog Devices, Inc., ALL RIGHTS RESERVED. This document may not be reproduced in any form without prior, express written consent from Analog Devices, Inc.

Printed in the USA.

Disclaimer

Analog Devices, Inc. reserves the right to change this product without prior notice. Information furnished by Analog Devices is believed to be accurate and reliable. However, no responsibility is assumed by Analog Devices for its use; nor for any infringement of patents or other rights of third parties which may result from its use. No license is granted by implication or otherwise under the patent rights of Analog Devices, Inc.

Trademark and Service Mark Notice

The Analog Devices logo, Blackfin, CrossCore, EngineerZone, EZ-Board, EZ-KIT Lite, SHARC, and VisualDSP++ are registered trademarks of Analog Devices, Inc.

All other brand and product names are trademarks or service marks of their respective owners.
CONTENTS

PREFACE

Purpose ........................................................................................................ vii
Intended Audience .................................................................................. vii
Manual Contents ..................................................................................... vii
What’s New in this Manual ....................................................................... viii
Technical Support .................................................................................... viii
Product Information ............................................................................... ix
  Analog Devices Web Site .................................................................... ix
  EngineerZone ...................................................................................... x
Notation Conventions .............................................................................. x

LICENSING OVERVIEW

Supported Operating Systems ............................................................ 1-2
System Requirements ........................................................................... 1-2
Note to VisualDSP++ Users ............................................................... 1-3
Licensing Terminology ......................................................................... 1-3
License Types ....................................................................................... 1-4
License Expiration and Subscription ............................................... 1-5
License Locking Options ..................................................................... 1-6
Licensing Options Summary ................................................................. 1-6
Obtaining a License Serial Number .................................................. 1-8
  Obtaining a Full License Serial Number ......................................... 1-9
  Obtaining an Evaluation License Serial Number ............................ 1-9
Locating License Serial Numbers .................................................... 1-9
Getting a PC Ready for License Activation ...................................... 1-10

ACTIVATING A LICENSE

Starting New License Wizard .............................................................. 2-2
Selecting License Type ....................................................................... 2-2
Entering a License Serial Number ...................................................... 2-4
License Activation Methods ............................................................... 2-5
  Activating a License in One Step .................................................. 2-6
  Delayed License Activation ......................................................... 2-8
  Validating a License ...................................................................... 2-10

ADMINISTERING A CORPORATE DOMAIN LICENSE

Determining Your Corporate Domain .................................................. 3-1
Locating a Corporate Domain License ............................................. 3-2
Activating a Corporate License ....................................................... 3-2
Distributing a License File ............................................................... 3-3
Backing Up an Existing License File ................................................ 3-3

TROUBLESHOOTING

Frequently Asked Questions (FAQs) ................................................ A-1
Installation Error Messages ............................................................... A-4
Contents

Installation Warning Messages ...................................................... A-8

LICENSING SUPPORT

E-Mail Support ............................................................................ B-1
Telephone Support ....................................................................... B-2
Information Required by Support ................................................. B-2
Thank you for purchasing CrossCore® Embedded Studio (CCES) for Analog Devices, Inc. processors.

**Purpose**

The *CrossCore Software Licensing Guide* describes how to manage licenses for CCES software.

**Intended Audience**

The primary audience for this guide is anyone who is working with CCES, a licensed product from Analog Devices. It describes the product licensing options, installation, and activation. The guide also includes the troubleshooting and FAQ sections for licensing issues.

**Manual Contents**

The manual consists of:

- Chapter 1, “Licensing Overview” on page 1-1
  Describes the available CCES licenses and introduces licensing options.

- Chapter 2, “Activating a License” on page 2-1
  Details how to install and activate a CCES license.
What's New in this Manual

- Chapter 3, “Administering a Corporate Domain License” on page 3-1
  Describes how to install and administrate a corporate CCES domain license.

- Appendix A, “Troubleshooting” on page A-1
  Explains commonly encountered error messages and provides answers to frequently asked questions.

- Appendix B, “Licensing Support” on page B-1
  Describes how to contact Analog Devices regarding licensing issues.

What's New in this Manual

This is the second revision of the CrossCore Software Licensing Guide. In the new revision, Appendix A, “Troubleshooting” has been modified based on the errata report against the previous revision of the guide.

Technical Support

You can reach Analog Devices processors and DSP technical support in the following ways:

- Post your questions in the processors and DSP support community at EngineerZone®:
  http://ez.analog.com/community/dsp

- Submit your questions to technical support directly at:
  http://www.analog.com/support

- E-mail your questions about processors, DSPs, and tools development software from CrossCore Embedded Studio or VisualDSP++®:
Choose Help > Email Support. This creates an e-mail to processor.tools.support@analog.com and automatically attaches your CrossCore Embedded Studio or VisualDSP++ version information and license.dat file.

- E-mail your questions about processors and processor applications to:
  processor.support@analog.com or
  processor.china@analog.com (Greater China support)

- In the USA only, call 1-800-ANALOGD (1-800-262-5643)

- Contact your Analog Devices sales office or authorized distributor. Locate one at:
  www.analog.com/adi-sales

- Send questions by mail to:
  Processors and DSP Technical Support
  Analog Devices, Inc.
  Three Technology Way
  P.O. Box 9106
  Norwood, MA 02062-9106
  USA

Product Information

Product information can be obtained from the Analog Devices Web site and CrossCore Embedded Studio online help system.

Analog Devices Web Site

To access a complete technical library for each processor family, go to http://www.analog.com/processors/technical_library. The manuals selection opens a list of current manuals related to the product as well as a link to the previous revisions of the manuals. When locating your manual title, note a possible errata check mark next to the title that leads to the current correction report against the manual.

Also note, MyAnalog.com is a free feature of the Analog Devices Web site that allows customization of a Web page to display only the latest information about products you are interested in. You can choose to receive weekly e-mail notifications containing updates to the Web pages that meet your interests, including documentation errata against all manuals. MyAnalog.com provides access to books, application notes, data sheets, code examples, and more.

Visit MyAnalog.com to sign up. If you are a registered user, just log on. Your user name is your e-mail address.

EngineerZone

EngineerZone is a technical support forum from Analog Devices. It allows you direct access to ADI technical support engineers. You can search FAQs and technical information to get quick answers to your embedded processing and DSP design questions.

Use EngineerZone to connect with other DSP developers who face similar design challenges. You can also use this open forum to share knowledge and collaborate with the ADI support team and your peers. Visit http://ez.analog.com to sign up.

Notation Conventions

Text conventions used in this manual are identified and described as follows.
<table>
<thead>
<tr>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close command (File menu)</td>
<td>Titles in bold style reference sections indicate the location of an item within the CrossCore Embedded Studio environment’s menu system (for example, the Close command appears on the File menu).</td>
</tr>
<tr>
<td>[this</td>
<td>that]</td>
</tr>
<tr>
<td>[this</td>
<td>that]</td>
</tr>
<tr>
<td>[this,...]</td>
<td>Optional item lists in syntax descriptions appear within brackets delimited by commas and terminated with an ellipsis; read the example as an optional comma-separated list of this.</td>
</tr>
<tr>
<td>.SECTION</td>
<td>Commands, directives, keywords, and feature names are in text with letter gothic font.</td>
</tr>
<tr>
<td>filename</td>
<td>Non-keyword placeholders appear in text with italic style format.</td>
</tr>
<tr>
<td><img src="image" alt="Note" /></td>
<td>Note: For correct operation, ... A Note provides supplementary information on a related topic. In the online version of this book, the word Note appears instead of this symbol.</td>
</tr>
<tr>
<td><img src="image" alt="Caution" /></td>
<td>Caution: Incorrect device operation may result if ... Caution: Device damage may result if ... A Caution identifies conditions or inappropriate usage of the product that could lead to undesirable results or product damage. In the online version of this book, the word Caution appears instead of this symbol.</td>
</tr>
<tr>
<td><img src="image" alt="Warning" /></td>
<td>Warning: Injury to device users may result if ... A Warning identifies conditions or inappropriate usage of the product that could lead to conditions that are potentially hazardous for devices users. In the online version of this book, the word Warning appears instead of this symbol.</td>
</tr>
</tbody>
</table>
1 LICENSING OVERVIEW

This chapter describes the licensing options available for CrossCore Embedded Studio (CCES) 1.0 users.

The following topics are covered:

- Supported Operating Systems
- System Requirements
- Note to VisualDSP++ Users
- Licensing Terminology
- License Types
- License Expiration and Subscription
- Licensing Options Summary
- Obtaining a License Serial Number
- Locating License Serial Numbers
- Getting a PC Ready for License Activation

If you have any questions related to CCES licenses or licensing, contact Technical Support.
Supported Operating Systems

CCES 1.0 is supported on the following operating systems:

- **Windows® XP Professional SP3** (32-bit only)
- **Windows Vista™ Business, Enterprise, or Ultimate SP2** (32-bit only)
- **Windows 7 Professional, Enterprise, or Ultimate** (32- and 64-bit)

Windows Vista and Windows 7 users may experience User Access Control (UAC) related errors if the software is installed into a protected location, such as Program Files or Program Files (x86). We recommend installing the software in a non-UAC-protected location.

System Requirements

Verify that your PC has these minimum requirements for the CCES 1.0 installation:

- 2 GHz single core processor
- 1 GB RAM
- 2 GB available disk space
- One open USB port

A faster disk drive decreases the build time, especially for a large amount of source files.
Note to VisualDSP++ Users

CrossCore Embedded Studio is a new Analog Devices product: the graphical user environment and full development tool chain for digital signal processor applications. Although some aspects of CCES licensing will be familiar to VisualDSP++ users, the VisualDSP++ licenses themselves cannot be used with CCES.

Licensing Terminology

License Activation

License activation is the process of unlocking the functionality of a CCES product by registering your serial number with Analog Devices. Activation includes license installation, registration, and validation, all in one step.

License Installation

License installation is the process of entering valid license information into CCES. A license that has been entered into CCES but not activated immediately is said to be “installed”.

License Registration

License registration is the process during which a user informs Analog Devices that a license has been installed. License registration results in a validation code.

License Validation

License validation is the process of entering an Analog Devices validation code into CCES. License validation completes the activation of an installed license.
License Types

Toolchain Evaluation Licenses

A toolchain evaluation license provides 90 days of use on activation after which it expires and becomes permanently disabled.

If installed but not activated, this license allows 10 days of operation (grace or trial period) before it expires and becomes disabled. The license can be re-enabled by activation.

A toolchain evaluation license can be activated once on a particular machine.

Add-in Evaluation Licenses

Certain add-ins, such as Micrium µC/OS-III™ Real-Time Kernel for CrossCore Embedded Studio, also have an evaluation license. Once activated, this license lets you install the add-in. You can install versions of the add-in with release dates up to 90 days after activation (see “License Expiration and Subscription” on page 1-5).

An add-in evaluation license can be activated once on a particular machine.

Full Licenses

A full license does not expire once it has been activated.

Activation starts the license subscription, determining which product versions are enabled, based on release date (see “License Expiration and Subscription” on page 1-5).

If installed but not activated, a full toolchain license allows 10 days of operation before it expires and becomes disabled. The license can be re-enabled by activation.
Licensing Overview

A full toolchain license can be activated a limited number of times, which allows the user to move the installation to a different machine.

A full license for an add-in (a CCES software component) must be activated to allow the add-in to install. There is no grace period with this type of license.

License Expiration and Subscription

License expiration and subscription are related but distinct terms. License expiration refers to overall viability of the license. For example, a toolchain evaluation license provides 90 days of use after activation, then expires. A full license, on the other hand, does not expire after activation. See “License Types” on page 1-4 for more information.

License subscription determines what product versions you can use with a license. The subscription starts when the license is activated and ends at the end of the subscription interval. Products released before the subscription ends can be used with the license. Products released after a subscription ends cannot be used with the license.

A subscription example: A full license with a one year subscription interval is activated on June 1, 2012. This license can be used with products that have release dates up to and including June 1, 2013. To use products with release dates beyond this date, the user needs to activate a new license. Note that you continue to use products that were released before the subscription ends even after the subscription itself has expired; the subscription determines whether or not newer versions of the product may be used.
License Locking Options

Node-Locked Licenses

Occasionally referred to as a *single-user license* or a *per user license*, a node-locked license is locked to the machine host ID of a specific host computer and provides a single license “seat”. Once installed, the product will run on that one computer only.

The machine host ID typically refers to the Media Access Control (MAC) address of the network card or motherboard. CCES uses MAC addresses as host IDs and supports the use of multiple MAC addresses in its licensing scheme.

Corporate Domain Licenses

Corporate domain licenses lock to a network domain name, such as *.*.subdomain.yourcompany.com.*

A license locks to one specific type of host ID. The license locking option cannot be changed.

Licensing Options Summary

Licensing controls the operation and installation of the CCES 1.0 features and components. The licensing options are summarized in Table 1-1 and Table 1-2.

Table 1-1. Licensing Options for CCES Toolchain

<table>
<thead>
<tr>
<th>Type Prefix</th>
<th>Evaluation - EVAL</th>
<th>Full - ADI</th>
</tr>
</thead>
<tbody>
<tr>
<td>Applies to</td>
<td>Full toolchain operation</td>
<td>Full toolchain operation. (For add-ins, see Table 1-2.)</td>
</tr>
<tr>
<td>Expiration</td>
<td>90 days</td>
<td>Permanent</td>
</tr>
<tr>
<td>Processor family</td>
<td>Blackfin and SHARC</td>
<td>Blackfin and SHARC</td>
</tr>
</tbody>
</table>
Licensing Overview

For example, an evaluation license for the CCES development toolchain
EVAL-CCES-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX:

- Has a serial number prefix of EVAL
- Allows use of the full development toolchain
- Expires 90 days after activation
- Allows use of Blackfin and SHARC processors
- Is node-locked to the MAC address (physical address of the network card) of a specific computer
- Does not have a subscription interval

does not have a subscription interval

Table 1-1. Licensing Options for CCES Toolchain

<table>
<thead>
<tr>
<th>Type Prefix</th>
<th>Evaluation - EVAL</th>
<th>Full - ADI</th>
</tr>
</thead>
<tbody>
<tr>
<td>Locking options</td>
<td>Node-locked</td>
<td>Node-locked or corporate domain</td>
</tr>
<tr>
<td>Subscription</td>
<td>None</td>
<td>1 year</td>
</tr>
</tbody>
</table>

Table 1-2. Licensing Options for CCES Add-ins

<table>
<thead>
<tr>
<th>Type Prefix</th>
<th>Evaluation - EVAL</th>
<th>Full - ADI</th>
</tr>
</thead>
<tbody>
<tr>
<td>Applies to</td>
<td>µC/OS-III add-in installation</td>
<td>Add-ins installation. (For toolchain operation, see Table 1-1.)</td>
</tr>
<tr>
<td>Expiration</td>
<td>Permanent</td>
<td>Permanent</td>
</tr>
<tr>
<td>Processor family</td>
<td>Blackfin and SHARC</td>
<td>Blackfin and SHARC</td>
</tr>
<tr>
<td>Locking options</td>
<td>Node-locked</td>
<td>Node-locked</td>
</tr>
<tr>
<td>Subscription</td>
<td>90 days</td>
<td>1 year</td>
</tr>
</tbody>
</table>
Obtaining a License Serial Number

A full license for the CCES development toolchain, 
ADI-CCES-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX:

- Has a serial number prefix of ADI
- Is permanent once activated
- Allows use of Blackfin and SHARC processors
- Is node-locked to the MAC address of a specific computer or a corporate network domain name
- Has a one-year subscription interval

A full license for an add-in, such as Micrium µC/OS-III 
ADI-[UCOS3]-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX:

- Has a serial number prefix of ADI
- Is permanent once activated
- Allows use of Blackfin and SHARC processors
- Is node-locked to the MAC address of a specific computer
- Has a one-year subscription interval

Obtaining a License Serial Number

This section covers the following topics:

- Obtaining a Full License Serial Number
- Obtaining an Evaluation License Serial Number

An evaluation license can be upgraded to a full license.
**Obtaining a Full License Serial Number**

A full license can be purchased from:

- Analog Devices, Inc. directly. Call (800) 262-5645 or 781-937-2384 or go to the buy online facility at [http://www.analog.com/en/content/buy_online/fca.html](http://www.analog.com/en/content/buy_online/fca.html)

- Depending on your location, Analog Devices, Inc. local sales office or authorized distributor. To locate one, go to [http://www.analog.com/salesdir/continent.asp](http://www.analog.com/salesdir/continent.asp)

A purchased copy of CCES is accompanied by the ADI serial number.

**Obtaining an Evaluation License Serial Number**

An evaluation license can be obtained from CrossCore Embedded Studio, which offers a toolchain evaluation license the first time it runs. CCES also offers an evaluation license for Micrium μC/OS-III the first time you install μC/OS-III.

An evaluation copy of CCES is accompanied by the EVAL serial number.

**Locating License Serial Numbers**

It is assumed that CCES 1.0 is installed on your computer.

To locate the serial numbers of licenses already installed in CCES:

1. Open the CrossCore Embedded Studio environment and choose Help > Manage Licenses. The Manage Licenses dialog box appears.
Getting a PC Ready for License Activation

The **Manage Licenses** dialog box is used to look up information pertaining to licenses installed on a computer and to perform various licensing tasks.

2. To copy the serial number of the license to the system clipboard, select the number and choose **Copy serial number** from the context menu.

3. To copy the entire license report to the system clipboard:
   a. Click **Report** to open the **License Report** dialog box.
   b. Click **Copy**.

**Tip:** Choosing **Help > Email Support** automatically creates an e-mail message to **processor.tools.registration@analog.com**, generates, and attaches the product information report to the message.

### Getting a PC Ready for License Activation

License activation requires TCP/IP network (Internet) access. Ensure that your PC is connected to the network.

If your license is node-locked, ensure your computer has a valid MAC address. On computers with Windows OS, you can view all current TCP/IP network configuration values by running the following command at the command prompt:

```
ipconfig/all
```

Docking or undocking a laptop may affect the MAC addresses availability.
The chapter describes the processes of entering a license string (serial number) into the CCES graphical user environment (GUI) and activating the license, as defined in “Validating a License” on page 2-10.

The following topics are covered:

- Starting New License Wizard
- Selecting License Type
- Entering a License Serial Number
- License Activation Methods
  - Activating a License in One Step
  - Delayed License Activation
  - Validating a License
Starting New License Wizard

To install a license, the license serial number must be entered into CCES via the New License Wizard.

To start the New License Wizard:

1. Navigate to CrossCore Embedded Studio Environment via Windows Start menu.

2. If the workspace launcher appears on the screen:
   a. Select your workspace.
   b. Click OK.

3. If the CCES is run the first time, click Yes to start the New License Wizard.

Thereafter, start the New License Wizard by choosing Help > Manage Licenses > New.

The New License Wizard appears.

The New License Wizard starts automatically the first time you run CCES or thereafter if no valid licenses are detected.

The New License Wizard also starts automatically the first time you install an add-in product.

Selecting License Type

The first time CCES is run, the New License Wizard (the Select License Type page) appears automatically (see Figure 2-1). The page also appears the first time you install the Micrium μC/OS-III add-in.
The toolchain evaluation license option is selected by default. If you have a serial number for a full license that you would like to activate, select the second option. When you have made your selection, click Next.

Figure 2-1. New License Wizard: Select License Type Page
Entering a License Serial Number

To enter a license serial number via the New License Wizard:

1. On the Enter your serial number page of the wizard, enter the number in Serial number exactly as it appears (including dashes).

Entering a valid serial number displays your computer’s host ID and enables the Next button. See Figure 2-2.

2. Click Next.

You successfully entered the license serial number.

Figure 2-2. New License Wizard: Enter your serial number Page
License Activation Methods

The following sections describe the process of license activation (installation, registration, and validation), as defined in “Licensing Terminology” on page 1-3.

After the CCES 1.0 license is entered in CCES, the license can be activated immediately or after a trial period. The license activation can be performed:

- In one step if your PC is part of the TCP/IP network (Internet). This is the most convenient license activation method, described in “Activating a License in One Step” on page 2-6.

- In three steps if your PC is not part of the TCP/IP network. The second method also is referred to as delayed activation and described in “Delayed License Activation” on page 2-8.

In step 1, you install the license. For toolchain licenses, this provides access to the entire CCES toolchain until the specified license expiration date.

In step 2, you register the license. This results in the validation code sent back to you via e-mail.

In step 3, you validate the license (enter the validation code sent to you). This unlocks the trial period, making the license permanent.

Corporate domain licenses and node-locked licenses are installed in the same manner, but a license file containing a corporate license can be distributed to multiple computers on the corporate domain. For more information about administering corporate domain licenses, refer to “Administering a Corporate Domain License” on page 3-1.
Activating a License in One Step

If your computer has an Internet connection, to activate a license in one step is the most convenient method.

You PC must be ready (see “Getting a PC Ready for License Activation” on page 1-10), and the license serial number must be entered in the New License Wizard (see “Starting New License Wizard” on page 2-2) for one-step license activation.

Follow this procedure:

1. On the Select license activation method page of the New License Wizard, Install and activate a license on-line all in one step is selected by default. See Figure 2-3.

Figure 2-3. Activating a License in One Step
a. If your computer has an Internet connection, do not make any changes.

b. If your computer does not have an Internet connection, or such a connection is isolated, select **Install a temporary license and then register it via website** and go to “Delayed License Activation” on page 2-8.

2. Click **Next**.

3. On the **Prepare for one-step license activation** page:
   
   a. Fill in the form. The required fields are marked by an * (asterisk).

   b. Click **Next**.

4. On the **Prepare for one-step license activation (continued)** page, complete the form.

5. Click **Finish**.

   The **Your license has been successfully activated** message concludes the one-step license activation. See **Figure 2-4**.

![Image: CrossCore Embedded Studio window with a message saying 'Your license has been successfully activated.']

**Figure 2-4. Your license has been successfully activated Message**

6. Click **OK** to return to the IDE.

You successfully activated your copy of the CCES 1.0 software.
License Activation Methods

If you received an error message during this procedure, refer to “Troubleshooting” on page A-1.

Delayed License Activation

If you cannot activate your CCES license immediately, delayed activation enables a customer to use the CCES toolchain for a specified trial period; the license activation date is delayed.

You also can install add-in licenses through delayed activation. When these licenses are activated, they permit add-in installation.

Your PC must be ready (see “Getting a PC Ready for License Activation” on page 1-10), and the license serial number must be entered in the New License Wizard (see “Entering a License Serial Number” on page 2-4) for delayed license activation.

It is assumed that the New License Wizard is open (see “Starting New License Wizard” on page 2-2).

On the Select license activation method page of the New License Wizard:

1. If your computer does not have an Internet connection or such a connection is isolated, select Install a temporary license and then register it via website.

If your computer has an Internet connection, to install and activate a license in one step is the most convenient method. Keep the
default selection, **Install and activate a license on-line all in one step**, and refer to “Activating a License in One Step” on page 2-6. See Figure 2-5.

![New License Wizard](image)

**Figure 2-5. Delayed License Activation**

2. Click **Finish**. The **License Registration Instructions** Web page appears. See Figure 2-6.

The **License Registration Instructions** page indicates that your license is installed but not registered. At this point, a CCES toolchain license provides 10 days of unrestricted toolchain use.
The page describes how to register your license, obtain a validation code, and complete activation of your license, with or without Internet access.

Licenses for CCES add-ins install but are not valid until registered and activated.

3. Complete the registration process as instructed.

Validating a License

You must validate your license in order to make the license permanent.

This procedure assumes that you have received a validation code via e-mail, and the CrossCore Embedded Studio IDE is open.
To validate a license:

1. Choose Help > Manage Licenses to open the Manage Licenses dialog box.

   The New License Wizard appears.

2. In the list of installed licenses, select the serial number of the license that you want to validate. This enables the Validate command.

3. Click Validate. The Enter Validation Code dialog box appears. See Figure 2-6.

   ![Figure 2-6. Enter Validation Code Dialog Box](image)

4. In Validation code, enter the validation code sent to you.

   Tip: Prevent typos by copying and pasting the code string.
5. Click OK.

The successfully entered validation code results in a message indicating that a permanent license has been created.

6. Click OK.

The license serial number is added to the list of serial numbers in the Manage Licenses dialog box. Note that the status icon next to the license serial number has changed.
This chapter describes how to create and install license files based on a corporate domain address.

Rather than locking to individual MAC (Ethernet) addresses, a corporate domain license locks to a network domain, such as *.subdomain.yourcompany.com. A license file containing a corporate domain license can be copied to multiple computers on the domain, potentially reducing overall administrative overhead.

The following topics are covered:

- Determining Your Corporate Domain
- Locating a Corporate Domain License
- Activating a Corporate License
- Distributing a License File
- Backing Up an Existing License File

**Determining Your Corporate Domain**

On computers with Windows operating system, you can view all current TCP/IP network configuration values by running the following command at the command prompt:

```
ipconfig/all
```
Locating a Corporate Domain License

The corporate domain is the value of the primary Domain Name System (DNS) suffix. The corporate domain license will be locked to this value, so all computers that use this license must have the same corporate domain value.

If the primary DNS suffix is blank, the computer is not on a domain, and a corporate domain license cannot be used.

Locating a Corporate Domain License

The CCES installer creates a folder on each computer that holds license files.

If you already installed a license and want to locate the license folder, follow the procedure in “Locating License Serial Numbers” on page 1-9. The complete path to the license file is at the beginning of the report.

On computers with Windows operating systems, the license folder usually resolves as:

- **Windows XP**: `<system drive>:/Documents and Settings/All Users/Application Data/Analog Devices/CrossCore Embedded Studio`
- **Windows Vista or Windows 7**: `<system drive>:/Program-Data/Analog Devices/CrossCore Embedded Studio`

On some computers, the license folder may be a hidden system folder.

Activating a Corporate License

The process of activating a corporate domain license is similar to the process of activating a node-locked license.
Administering a Corporate Domain License

Follow the instructions in “Activating a License in One Step” on page 2-5 or “Delayed License Activation” on page 2-8 to activate your corporate license.

Validation codes for corporate domain licenses are sent via email regardless of the activation method.

Distributing a License File

At this point, there should be a license.dat file in the license folder that contains the corporate domain license. This file can be copied to the license folder of each computer that is to be covered by the corporate domain license. CCES 1.0 must be installed on each of these computers to make the application available and to create the license folder.

Backing Up an Existing License File

If there is an existing license.dat file in the license folder, make a backup copy of it, then delete the original.
A TROUBLESHOOTING

This chapter provides answers to common licensing problems and includes the following sections:

- Frequently Asked Questions (FAQs)
- Installation Warning Messages
- Frequently Asked Questions (FAQs)

If you still have questions related to CCES licenses or licensing after reading this chapter, contact Technical Support or Licensing Support.

**Frequently Asked Questions (FAQs)**

**Question:** I have lost my serial number. Where can I find it, or how do I get a replacement?

**Answer:** You can locate already installed serial numbers in the CCES IDE: Help > Manage Licenses. Refer to “Locating License Serial Numbers” on page 1-9 for more information.

If you do not have CCES installed and licensed, e-mail Analog Devices with details of the person and company to whom the serial number was originally registered. For more information, refer to Technical Support or Licensing Support.
Question: I’ve just installed a toolchain evaluation license using the “Install a temporary license and then register it via website” option of the New License Wizard. Now I get a message telling me that the license will expire in X days. I thought licenses were permanent?

Answer: When evaluation licenses are installed this way, they have an initial grace period. An evaluation license runs for 90 days after activation. In order to unlock the complete evaluation period, an evaluation license must be validated.

Full toolchain licenses installed via the Install a temporary license and then register it via website option of the New License Wizard also have an initial grace period but become permanent when validated. Refer to “License Activation Methods” on page 2-4 for more details.

Question: I’ve just installed a full license for a CCES add-in using the Install a temporary license and then register it via website activation option of the New License Wizard. Now the status of the license shows as ‘Expired’. Doesn’t this license have a grace period?

Answer: This type of license has no grace period: it must be validated to enable installation of its component. Refer to “License Types” on page 1-4 for more details.

Question: What is the difference between license ‘expiration’ and license ‘subscription expiration’?

Answer: When a license is expired, it does not allow its products to be used at all. License subscription applies to licenses that are not expired and allows product use based on a product release date. See “Licensing Terminology” on page 1-3 for more information.
Question: How do I transfer my license to a new machine?

Answer: Use the New License Wizard to activate your license on the new machine. If activation fails with a message “The license has already been registered the maximum number of allowed times”, request a registration history update via e-mail to processor.tools.registration@analog.com. Include the serial number(s) in question.

Question: How can I find out my registration history? That is, how do I find out which machines my serial number(s) are registered against?

Answer: To request an up-to-date registration history, send an e-mail with the serial number(s) in question to processor.tools.registration@analog.com.

Question: I’ve just installed a license using the Install a temporary license and then register it via website activation option of the New License Wizard. The validation code that was e-mailed to me is being rejected. What could be the problem?

Answer: Validation codes are valid for a particular serial number and host ID combination. If you are trying to activate your serial number on a second computer, you will have to register it on the new computer in order to receive the appropriate validation code.

For more information, refer to “License Activation Methods” on page 2-4.

Question: Where is the license.dat file on my computer?

Answer: There is only one license.dat file for all CCES installs on a computer, and it is located in the license folder. The full path to the
license file is given in the report generated by Help > Manage Licenses > Report or by Help > Email Support.

Note: The license folder may be a hidden system folder on some computers.

**Question:** How do I install both a node-locked license and a corporate domain license on the same machine?

**Answer:** Licenses of all types can coexist on the same machine. Use the New License Wizard to activate both licenses.

If you intend to install the corporate domain license on many machines, refer to “Determining Your Corporate Domain” on page 3-1.

**Installation Error Messages**

This section describes some common error messages issued during license installation and validation.

**Problem:** A valid license could not be found.  
*Click Yes to install a license at this time.*  
*Click No to close CCES.*

**Solution:** This message appears the first time CCES starts up or thereafter if there are no current licenses installed. Selecting Yes starts the New License Wizard.

**Problem:** A valid license could not be found.  
*Click Yes to manage your license(s) now.*  
*Click No to close CCES.*
Solution: This message appears if licenses have expired. Selecting Yes opens the Manage Licenses dialog box.

Problem: There was a problem installing the license for this serial number. Reason: Invalid license file. The license file may be obsolete, corrupted, missing, or read-only.

Solution: This indicates a problem with the license.dat file. For example, the license file is a VisualDSP++ license file that is incompatible with CCES. Check the contents of license.dat located in:

- Windows XP. <system drive>:/Documents and Settings/All Users/Application Data\Analog Devices/CrossCore Embedded Studio
- Windows Vista or Windows 7. <system drive>:/Program-Data/Analog Devices/CrossCore Embedded Studio

Also ensure that the file is not read-only. If the problem persists, contact Technical Support.

Problem: There was a problem installing the license for this serial number. Reason: A valid Host ID could not be found.

Solution: Host ID information for your system can be found through the Manage Licenses dialog box in the CCES IDE via Help > Manage Licenses > Report or Help > Email Support.

Licenses locked to an Ethernet (MAC) address require a physical TCP/IP network address to be available on the computer. This error can occur if there is no network card installed.

Licenses locked to a disk serial number require a valid volume serial number. This error can occur if there is no C: drive installed, for example.
Corporate domain licenses require that the computer be on a domain. Refer to “Determining Your Corporate Domain” on page 3-1 for more information.

**Problem:** There was a problem installing a license for this serial number. **Reason:** The serial number has already been used and can be installed only once.

**Solution:** The serial number you are trying to install has been installed already on this computer. For further information, refer to “Licensing Terminology” on page 1-3.

**Problem:** There was a problem activating the license. **Reason:** There was an error during activation. This may be due to the following:

- network outage
- firewall blocking access to the ADI activation server
- maintenance of the ADI activation server

**Solution:** This can occur during one-step activation. First, open a web browser and confirm that you can open the URL http://www.analog.com without any network or firewall problems. Then try activating the license again in the New Licenser Wizard. If you were on the last page of one-step licensing activation when you closed the error dialog box, just click Finish again to complete activation.

If you still are unable to activate the license through one-step activation, on the Select license activation method page of the New License Wizard, select the Install a temporary license and then register it via website option. Follow the License Registration Instructions to register and validate your license.
**Problem:** There was a problem registering the license. Reason: The license has already been registered the maximum number of allowed times. Details: Registration limit exceeded.

**Solution:** Full and evaluation licenses can be activated a limited number of times. Contact Technical Support with your current serial number, and we will help to activate your current license or issue a replacement license, depending on the circumstances.

**Problem:** The license was successfully installed, but there was a problem completing on-line validation. You can register and validate your license manually by selecting Help, Manage Licenses.

**Solution:** The Manage Licenses dialog box lists the installed licenses. See “License Activation Methods” on page 2-4 for more information.

**Problem:** The license file was successfully installed, but there was a problem opening the registration website.

**Solution:** This can occur due to a browser problem, for example. The Manage Licenses dialog box lists the installed licenses. See “License Activation Methods” on page 2-4 for more information.

**Problem:** There was a problem validating the license. Reason: The validation code is invalid. Please re-enter the code, ensuring that you type the code EXACTLY as you received it. It might be helpful to copy-and-paste your validation code rather than typing it manually.

**Solution:** CCES detected that you entered an invalid validation code. Ensure that you have entered the correct validation code, exactly as given.
Installation Warning Messages

Validation codes are valid for a particular combination of serial number and host ID. If you are trying to install your serial number on a different computer than the one you initially registered, you need a new validation code. Refer to “License Types” on page 1-4 for details.

Installation Warning Messages

This section describes common warning messages issued during license installation and validation. These messages display in message boxes, dialog boxes, the Console view, and command prompt.

Warning (in message boxes): <serial number> expires in x days

-- or -- <serial number> expires today.

Solution: If the given license has not yet been validated, it is in its grace period and will expire in x days (or today.) Refer to “Validating a License” on page 2-10 for details.

An evaluation license that has been activated also displays this message as it reaches the end of its life.

Warning (in dialog boxes): The Subscription Expiration dialog box appears at startup if any license subscriptions are due to expire soon.

Solution: To prevent the re-display of messages for these licenses, select Do not show this message for these licenses again and click OK.

Warning (in the Console view or command prompt):
[Informational ea1154]
License to use this tool will expire in x days
**Solution:** The assembler has detected that your license will expire in $x$ days. If you have an evaluation license or a full license, register and validate it.
If you are still experiencing a problem after having tried to solve it using the information in this guide, contact Analog Devices Customer Support for assistance.

The chapter contains the following sections:

- E-Mail Support
- Telephone Support
- Information Required by Support

E-Mail Support

You can obtain support via e-mail as follows:

Registration Support:

Contact Registration Support if you have any problems with registering or validating your license serial number, or if you have lost your license serial number. Use the following e-mail address:

processor.tools.registration@analog.com

Processor Tools Support:

For all other queries regarding CCES licensing, contact Processor Tools Support. Use the following e-mail address:

processor.tools.support@analog.com
Tip: Choosing Help > Email Support automatically creates an e-mail message to the above address, generates, and attaches the product information report to the message.

**Telephone Support**

In the USA only, licensing enquiries can be made to the following toll-free phone number: **1-800-ANALOGD** (1-800-262-5643).

**Information Required by Support**

When contacting Customer Support regarding a licensing issue, have the following information ready (send by e-mail or have it available if telephoning):

- Version of CCES
- License serial number(s) in question
- The `license.dat` file (if available)
- Screen captures of encountered error messages

Tip: Choosing Help > Email Support automatically creates an e-mail message to processor.tools.registration@analog.com generates, and attaches the product information report to the message.